I tried to run a game on a family member's computer and go a strange error: Apparently it got an Access Denied error message when creating a file in the temp folder. Since permissions should be standard user profile permissions I went into the permissions editor for the folder, set it to replace all permissions on child objects to the current permissions, an hit apply.

This is what I got

enter image description here

There were a couple of other files that had this issue as well. I'm extremely puzzled by this error though as the user should have access to everything in the folder. This complicated by the fact that I can create a text document, edit, and save it no problem but my game even running as an administrator can't create its temp file

Things I've tried

  1. Reboot (clears the temp folder and also fixes a lot of windows problems)
  2. Running Explorer as an administrator
  3. Checked that there were no viruses with Security Essentials

I'm puzzled on how to continue. Does anyone have any suggestions?


You can't apply new security permissions without having ownership of the folder first.

You need to take ownership, and then click OK all the way out of there, before you can go in and change the security as you want it in your screen capture.

  • Hmm, strange. Took ownership of the folder, applied permissions successfully, aaand... access denied. Fired up Procmon and aw that a bunch of other temp folder reads and writes went through but only creating a single temp file failed. Absolutely no idea why – TheLQ May 28 '12 at 22:57
  • 1
    Did you try with the TAKEOWN /F <path> /R /A command line? – user3463 May 28 '12 at 23:00
  • Yep, same result. – TheLQ May 29 '12 at 0:22
  • I've just tried it and it works on my machine. Perhaps you need to run a CHKDSK /F on the drive to make sure the partition is ok. – user3463 May 29 '12 at 2:12

Try creating a new Temp folder. Personally, I hate that Microsoft moved the Temp folder to be umpteen subfolders deep, so I always create a new one at C:\Temp.

Change the TMP and TEMP environment variables for both the user and the system to C:\Temp, then reboot. Then try to play your game again.

Once the game has been fixed, delete the old Temp contents. There will be one under each login under C:\Users, and one under C:\Windows.


Just delete the entire contents of %Temp% folder, ignore any file that refuses to be deleted, try to take permissions again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.