Router (primary AP) is a WRVS4400N, WAP (signal booster) is a WAP4410N.

Problem: User is physically located within ten feet of WAP (>200 feet from main wireless router). Signal is at 5 bars as user connects to wireless network. Within seconds, signal is at or below two bars and connection is poor.

Background: Trying to solve problem of weak wireless signal in back offices. Desired result is for client laptops to automatically switch to the stronger signal.

  • WAP is connected to network via Ethernet cable.
  • WAP is set to AP mode (instead of Wireless Repeater mode)
  • WAP does appear to boost signal. Using Windows 7 sys tray Connect To A Network applet, can observe signal boost as laptop approaches the WAP.
  • Above-described problem happens to users located near or beyond the WAP. It does not happen to users in close proximity to the router.

Secondary Question: If using WAP in AP Mode, do WAP and Router (primary AP) need to be on the same channel?


No, they do not need to be on the same channel. In fact, they can (and most likely will) interfere with each other if they are on the same channel. If you choose channel 1 for the router, try setting the WAP to 6 or higher, as this will be more than 20MHz above channel 1, and standard channels are 20MHz wide. A portion of the channels overlap each other, as can be seen in this image...

enter image description here

As to what is happening, if both the Router and the WAP have the same SSID, it sounds like the computer that is connecting to the WAP is then switching over to communicate with the Router itself.

You can temporarily turn off the WAP, and see if the computer can even see the router from there, and the signal strength. If the signal strength is at or below two bars... then indeed the computer may be connecting first to the WAP then the router. You can also try temporarily changing the SSID of the WAP to see if the computer connects and then disconnects from it. It could be an issue with the WAP itself.

At the very least, I would try these things I mentioned. Change the channel on the WAP to something more than 20MHz away (1-6, 2-7, 3-8, 4-9, 5-10, 6-11), see if the computer can connect to just the router, and try using a different SSID for the WAP.

  • Good ideas, thank you. I'll give them a try and post an update. – cssyphus May 31 '12 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.