I have a strange problem with Internet Connection Sharing on a laptop running Vista Business. This laptop is connected to the internet via the ethernet port, which goes to an ADSL modem. it is automatically assigned the IP address, and the modem/gateway is

My friends laptop is running Vista Home. Previously, I would create an ad hoc wireless network, enable ICS, and everything would be perfect. My friend would have internet access via this.

However, something has now mysteriously broken. If I enable ICS on the wireless connection, it resets my Local Area Connection, assigning it the manual IP address of, which means my connection to the internet is destroyed. Both wireless adapters on each network are assigned auto configuration addresses, in the 168. range.

They can see each other fine, but my friends laptop cannot access the internet via mine, even after I have restored the Local Area Connection settings.

I understand the computer with ICS enabled must have the IP of, but previously, before whatever went wrong, my wireless adapter would be and my friends computer would get an IP via DHCP.

I have also tried setting static IP address and making a bridge, none of which works. How can I fix this problem, and prevent enabling ICS from touching my Local Area Connection?

Both machines have no firewall, have appropriate settings etc...


this is perfectly normal. to enable ICS you'll need 2 NICs in your computer (or 1 modem + 1 NIC if on dial up).

NIC #1 ( connects to your router (the internet) via DHCP, NIC #2 is on a static address (IP and the internet connection on NIC #1 is shared. now another computer can connect to NIC #2 (either static with IP & DNS or via DHCP).

if NIC #2 is a wireless adapter it must support AP mode in order to get it working. so make sure access point mode is enabled for your wireless adapter.

  • Nooooo. The problem is that NIC 2 should be the ICS enabled NIC with the static IP of, but instead, enabling ICS overwrites the settings for NIC 1, thereby destroying the internet connection. This is not notmal behaviour, and was not happening previously. – Bill Grey Sep 18 '09 at 0:30
  • when you enable ICS, you'll be asked for a connection to share, there you'll have to select NIC #2, then NIC #1 will be configured for static address. – Molly7244 Sep 18 '09 at 0:38
  • Yes, I know. The problem is that sharing my internet connection has resulted in the internet connection itself being configured in such a way as to lose internet. This is abnormal behavior, and has only started happening recently. – Bill Grey Sep 18 '09 at 1:47
  • the key here is AP mode, did you change the controller settings recently? it must be configured as access point. – Molly7244 Sep 18 '09 at 2:15
  • My driver does not have any option to enable or set AP mode, and I did not previously set it. No driver settings have been changed at all, and I can set up an adhoc network without a problem. – Bill Grey Sep 18 '09 at 15:11

I suggest reinstalling the NICs drivers, or maybe a system restore can solve this.

  • Already tried, and no, a system restored changed nothing... – Bill Grey Sep 18 '09 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.