4

I'd like to know how I can make GIMP 2.8 (the latest stable release) open in a maximised window. Every time I open it I have to click on the maximise button so that I can see the complete window and frankly it's getting annoying.

I'm using the new Single-Window Mode, which probably helps. I've tried the method of choosing "Maximized" in the Properties of a shortcut, but that just maximises the splash screen, and the actual window is still un-maximised.

I'm using Windows 7 Ultimate 64-bit. If anybody could help this would be awesome, I use GIMP very often.

By the way, I'd also like to know if anybody knows how I can open most common image files with the "Edit with GIMP" option in the right-click menu. I made some .reg files that would do this with GIMP 2.6, but even after editing the .reg files and using them, if I click the option it will ask me to choose a program to open with. Except for with .gif files, those open properly.

  • Now with GIMP 2.10 out, the reg file needs to be adjusted accordingly. Windows Registry Editor Version 5.00 [HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\Edit with GIMP] [HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\Edit with GIMP\command] @="\"C:\\Program Files\\GIMP 2\\bin\\gimp-2.10.exe\" \"%1\"" – AlienDrew May 5 at 3:35
8

According to the person who actually compiles GIMP on Windows, the problem is related to the GTK+ toolkit. And this makes sense, because GIMP isn't the only linux port to suffer from this annoying problem.

Updating to GIMP 2.8.4 (or higher) will resolve the issue in Single-Window Mode.

Otherwise, you will have to find a third-party program that can automatically maximize windows for you. I am not aware of any free ones but Actual Window Manager will do the job. If it's a bit too pricey, you may be able to get the same functionality from some of their cheaper programs such as Actual Window Guard or Actual Window Minimizer.

In regards to your second question, you can use the following registry script to add the 'Edit with GIMP' option to system image types assuming you have GIMP 2.8 installed to the default directory:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\Edit with GIMP]

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\Edit with GIMP\command]
@="\"C:\\Program Files\\GIMP 2\\bin\\gimp-2.8.exe\" \"%1\""
  • Thanks! I had a similar registry script before, but apparently it didn't work because it didn't have the double-slashes in the path. I'll check out some of those maximization programs, too. – puggsoy Jun 2 '12 at 9:52
  • Quick note for those, like me, who had to do a quick refresher on regedit scripts: copy above into text file, save as whatevs.reg, open regedit, file, import, select the .reg file you just saved, job done. – dartacus Jan 3 '18 at 9:14
  • Now GIMP apparently installs the context menu option by default. I don't see an undo in GIMP's settings. Am I correct in thinking the context menu option is removed via [-HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\Edit with GIMP]? – Ray Woodcock Jan 18 at 8:03
2

To maximize GIMP once it has loaded, you can use AutoHotkey as demonstrated in my answer here: https://superuser.com/a/430863/100787. From there, you can download my icon Maximize executable or compile the script yourself which can then be called from the command line, shortcut, or batch script.

Example:

Maximize "GNU Image Manipulation Program" "%ProgramFiles%\GIMP 2\bin\gimp-2.8.exe"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.