I have a very specific problem. A client of mine has an old server that has some very old software that cannot be re-installed (or maybe it can? I can read from the drive when mounted to another system as a usb storage device.) because the original software sources are gone.
The client got the bright idea to install some new drivers, including the latest NVIDIA driver. This driver killed the system, now on boot the windows loading screen gets to 2 'blips' then freezes (complete system freeze, nothing is responding - hard boot is the only option).

after two days of fiddling I was able to get into the F8 recovery menu (by moving the HDD image to a usb drive and booting from that... idk why this worked. I still had to be quick on the F8 or else the system would freeze again).

trying to boot into safe mode, or the recovery utility spits out this error:

DISK I/O ERROR: 00000400
DISK I/O ERROR: 00000400

Now, i'm not picky on how I solve this issue, so long as the system gets restored with all it's original software installed :S ( I know this is asking for a lot ).
How would I start fixing this problem? Every article i've read on similar issues just say "backup, replace, restore". but the hardware is working fine. Please a nudge in the right direction?

UPDATE 05-29-2012

So it seems my I/O error were caused by the USB device... Sorry Bruno!
I copied the drive image to a new HDD (went digging for one from another pc) and was able to get to the recovery menu... same problems however (with the exception that there are no longer I/O errors!) it still hangs after multi(0)disk(0)rdisk(0)Partition(1)\WINNT\System32\system.alt

  • nope, worked fine actually. both had the same errors, I actually got further with the usb device. either way this is not the cause of the problem, this was an attempt to track down the cause. – rlemon May 29 '12 at 19:34
  • @BrunoPereira I first copied it to the USB (because no other HDD was around) to verify that it was not a bad hdd. the F8 was not working from the internal disk, but was working on the USB... but don't get me wrong the USB still freezes, there is just a few ms delay so I can F8 before it hits the errors. – rlemon May 29 '12 at 19:35
  • but how do I re-install but keep the original software? like I kid you not, this stuff is ten years old and the installers have gone the way of the dinosaur. – rlemon May 29 '12 at 19:41

Now that you can half boot from it - and you have an image of the original installation in 2 different disks - you can insert a Windows2K CD in to the drive, boot from it and once it has booted you can try to repair the install using the CD.

The first setup screen should allow you to do it

enter image description here

It will ask you for a recovery disk from the system (which you probably don't have) or give you the option to locate an installation for you, select that option and let the setup finish.

Try to boot again from the hard disk and pray that it works.

  • Emergency repair process? I went into the recovery console, but I wouldn't even know where to begin rolling back drivers. – rlemon May 29 '12 at 20:46
  • The repair process (automatic) will try to revert any installed drivers if I am not mistaken, you should try that one first. – Bruno Pereira May 29 '12 at 20:47
  • hehe the repair process 'could not find a windows 2000 installation" but the XP recovery finds it! :P the XP recovery allowed me to fix some stuff (admittedly I'm just trying anything I can now) but now it's in an endless boot loop. all progress on the windows loading screen fills up then the pc restarts. – rlemon May 30 '12 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.