I'm running Windows 7 64-bit and I'm trying install VMware Player 4.0.3.

I get an error:

The MSI 'C:\users.....\Local\Temp\vmware_1338456060\vmwarevmcisockets64.msi' failed.

I had installed this previously, and had to uninstall the application. This attempt was a re-install.


Documenting VMware Player 4.0.2 Install on a Windows 7 64-bit Host OS

Hurdle #1 Getting the installer to work:

  • Create folder C:\Temp if it doesn't already exist. Delete everything in there and put the self-extracting executable in it. In my case the file is called VMware-player-4.0.2-591240.exe. Open up your command prompt (Start->Run->cmd.exe) and then navigate to the folder where the .exe file is located by typing cd C:\Temp. Then type this C:\Temp>VMware-player-4.0.2-591240.exe /e
  • Download InstEdit (trust me you will need it because some shmuck at VMware didn't test their installation packages throughly)
  • Start the installation by running C:\Temp\VMware-player-4.0.2-591240.exe. This creates a folder inside C:\Users\%username%\AppData\Local\Temp\vmware_%random_number%. (In my case this is where installation stopped prematurely) copy this folder \vmware_%random_number% into C:\Temp\ folder.
  • If you are getting "Error 2732. Directory Manager not initialized" message when you try to start the player then follow instructions here. Instructions are a little hard to follow but you will get through it eventually. Running msiexec with /qn option [/q Sets User Interface level /n Sets it to None] was what did it for me so don't mess with these options. Player will "quietly" install and you won't even know it's there until you check your Start menu.

Hurdle #2 Getting VMPlayer to run the ISO image:

Of Course it didn't end there!!! There was one other error I was getting when I tried to install CentOS_64-bit from an ISO image. This error below:

Could not get vmci driver version: The handle is invalid. You have an incorrect version of driver "vmci.sys". Try reinstalling VMware Workstation. Module DevicePowerOn power on failed.

  • First you have to download the proper "vmci.sys" driver file. See this link for a mini walk through on how to do that. If you're on a 64bit machine make sure to copy vmci.sys file into your C:\Program Files(x86)\VMware Player folder as well as C:\Windows\System32\drivers
  • Again if you're on a 64-bit machine then open up your .vmx file and change this setting vmci0.present = false.

This sums up 4 Hours of my life I will never get back, but now I have a VMware Player up and running on my Windows 7 64bit system. Hope this helps...

PS: If and when you get a notification from VMWare player to update/upgrade to a newer version you will not be able to do so because the installation/upgrade package is still broken. Possibly uninstalling the current version and reinstalling using the new file following the steps from above might help you resolve the issue.


Try this, and do not forget to create a restore point before following the steps ahead.

  1. Open regedit.
  2. Click on Find which may be a submenu of Edit.
  3. Search for VMware, delete all the registry entries for VMware.
  4. Delete temp/%temp/prefetch data.
  5. Try reinstalling.
| improve this answer | |
  • Did this work for someone? – Jaanus Jun 1 '12 at 10:59

In my case this was due to the TEMP path being changed from the default. You have to restore the default one in the registry (temporanly overring the environment variable does not work).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.