This morning I attempted to run Windows Update on two of my Windows 7 PCs (both are virtual machines), and I ran into this interesting pop-up error message. I have never encountered this problem before, so I was somewhat perplexed.

enter image description here

From the message, my first thought was to see if the Windows Update service was running. It was. As usual, the solution is never so simple. I attempted to restart the service and reboot the PCs to no avail.

enter image description here

So, I am off to the interwebs for a solution. I did find a solution to the problem, so I thought to post it for my future reference and for anyone else who may encounter this problem. I will be posting the answer shortly.

If you have alternate solutions that have worked for you, please feel free to leave a post or comment.

  • Pay attention to the fact that by default windows update service is set as delayed by default. If you try to start using it on the first seconds after a boot you will get the samed error.
    – Diogo
    May 31, 2012 at 16:34
  • 1
    – Moab
    May 31, 2012 at 19:46

5 Answers 5


Apparently, the problem is with a corrupted windows log file.

In order to get Window Update running again, you have to:

  1. Go to Services, and temporarily Stop the "Windows Update" service
  2. Go to c:\windows\softwaredistribution\datastore\logs\
  3. Find the file edb.log
  4. Rename or delete the file
  5. Once the file is renamed or deleted, go back to Services, and Start the "Windows Update" service
  6. Try to run Windows Update again. It will work normally.

So far, I have not had any problems with this solution. I have successfully installed updates on one of the PCs.


  • 4
    For me (Windows Server 2008), it was enough to stop service "Windows Update" for the deleting/renaming. So the reboot to Safe mode may not be necessary. Jul 30, 2012 at 9:32

Essentially the same thing as the answer above, but a little easier in my opinion:

  1. Stop the Windows Update service under services.msc (leave the services window open)

  2. Go to C:\Windows

  3. Rename the SoftwareDistribution folder to something like SoftwareDistribution_OLD

  4. Go back to services and start the Windows Update service (this will also create a new SoftwareDistribution folder automatically)

  5. Wait a few minutes and try again!

  6. If it works and you want, go ahead and delete the SoftwareDistribution_OLD folder, otherwise you can revert back

This has worked numerous times for me. Although, full disclosure, I have never checked Windows Update History to see if it still knew what updates were installed and when. The machine is smart enough though to know going forward what updates you do and don't need. My two cents!

  • 1
    This worked great for me - the key was that I have to WAIT A FEW MINUTES on step 5. The first time I tried, I must've been too quick for it to refresh. Thanks much :-).
    – Mister_Tom
    Jul 3, 2012 at 20:34

Here's a really non-technical fix, but it seems to work consistently among people who have this problem with Windows 7 or Vista.

Go to your windows update settings, and change it to "Never Check for Updates". Apply the change.

Then change the setting again to your preferred option. I used "Check for updates, but let me choose whether to download and install them". Apply this change.

Once I applied the second change, the updating process returned to normal.


From Microsoft: Windows 7 - Windows Update not working

Check if the Windows Update Service is running. Control Panel > Administrative Tools > Services

If the Windows Update service is not running, try starting it (it should be on automatic start)

The Windows Update service depends on the DCOM and the RPC services, so if not running you may need to start them.

Failing that, you might need to do a repair install.

  • 2
    Don't just copy and paste content from somewhere else. At least quote it properly and include a link to the source.
    – slhck
    Jun 2, 2012 at 8:25

This is what helped to me in the same situation. Run this in command prompt:

regsvr32 wuapi.dll
regsvr32 wuaueng.dll
regsvr32 wups.dll
regsvr32 wups2.dll
regsvr32 wuwebv.dll
regsvr32 wucltux.dll

Re-registering DLLs helped in Windows 7 environment.

Not the answer you're looking for? Browse other questions tagged or ask your own question.