25

In alsamixer, there is an option called "Auto-Mute Mode", and it's enabled by default.

But now I want to disable it. I've tried different keys but failed.

Any idea? 0_0

enter image description here

24

Press right arrow to get to "auto-mute mode", then up or down arrow to change it, then Escape to exit.

You can make this automatic on boot by executing (perhaps in /etc/rc.local):

/usr/bin/amixer -c 0 sset "Auto-Mute Mode" Disabled
  • @Sam And would you have any idea on how to make this change permanent? Every time I restart my pc it gets reset. – Akshet Sep 9 '12 at 19:19
  • 1
    try google: alsa save mixer settings – Sam Watkins Oct 26 '12 at 5:24
  • 1
    I would like to disable auto mute mode, but I don't have it, and amixer -c 0 contents doesn't show anything to that effect, and amixer -c 0 sset "Auto-Mute Mode" Disabled returns "Unable to find simple control 'Auto-Mute Mode',0". When I plug in my headphones, the speakers stop playing, though. Any ideas how I can change the setting? – Limited Atonement Oct 24 '15 at 21:15
  • 2
    @LimitedAtonement I don't know. Perhaps your sound device isn't fully supported by Linux kernel drivers, or perhaps the "auto mute" is done in hardware and can't be overridden in software. – Sam Watkins Oct 26 '15 at 9:59
  • 1
    @LimitedAtonement ^ for future reference: it could also mean that you have multiple sound devices (e.g. HDMI) and you may want to explore say -c 1 and so on – norok2 Jan 21 '17 at 18:26
7

Late answer.

I had the same problem, including @limited-atonement one.

To resume:

root@darkstar:~# amixer | grep -i mute
Simple mixer control 'Auto-Mute Mode',0
root@darkstar:~# amixer -c 0 sset 'Auto-Mute Mode' Disabled
amixer: Unable to find simple control 'Auto-Mute Mode',0

I solved it by running alsamixer, then:

  • F5 (show all controls)
  • use arrows to move until hitting the <Auto-Mute> control, which show as Enabled
  • use the minus - key to switch it to Disabled
  • hit Esc to exit
  • run alsactl store as root to save

Hope this help.

3

Building on Sam's answer, here is a script that toggles the status of Auto-Mute Mode:

# toggle status of Auto-Mute
if amixer -c 0 sget 'Auto-Mute Mode' | grep --quiet -F "Item0: 'Enabled"
then
    amixer -c 0 sset 'Auto-Mute Mode' Disabled
else
    amixer -c 0 sset 'Auto-Mute Mode' Enabled
fi

I'm using this so I can easily mute or un-mute my speakers without unplugging my headphones.

Edit: one-liner

amixer -c 0 sget 'Auto-Mute Mode' | fgrep -q "Item0: 'E" && _M=Disabled || _M=Enabled; amixer -c 0 sset 'Auto-Mute Mode' $_M

protected by Community Oct 8 '18 at 20:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.