6

In diskpart, when I type select disk 1, then select partition 1, I get

No partition selected

The USB is FAT 32. Basically, I am trying to do set id=af on my flash drive.

migrated from stackoverflow.com Jun 1 '12 at 8:16

This question came from our site for professional and enthusiast programmers.

  • 1
    Have you tried LIST PARTITION? The drive might not be partitioned. – Harry Johnston Jun 4 '12 at 1:30
3

Because the partition is already selected. You should see an asterisk * to the left of the listed partition.

  • 4
    "No partition selected" appears to be the exact opposite of "the partition is already selected". – Kevin Brown Jul 12 '16 at 1:51
2

If you select an object for a second time, diskpart still emits a message indicating that the object is selected. Harry's question is valid. What do you get when you select the Flash Drive and then LIST PARTITION?

Here's a transcript of a diskpart session, for reference:

DISKPART> list disk

  Disk ###  Status         Size     Free     Dyn  Gpt
  --------  -------------  -------  -------  ---  ---
  Disk 0    Online          596 GB    11 MB
  Disk 1    Online          954 MB      0 B

DISKPART> select disk 1

Disk 1 is now the selected disk.

DISKPART> list part

  Partition ###  Type              Size     Offset
  -------------  ----------------  -------  -------
  Partition 1    Primary            953 MB    64 KB

DISKPART> select part 1

Partition 1 is now the selected partition.

DISKPART> list part

  Partition ###  Type              Size     Offset
  -------------  ----------------  -------  -------
* Partition 1    Primary            953 MB    64 KB

DISKPART> sel part 1                             # Second Select Part

Partition 1 is now the selected partition.       # same "object selected" message

DISKPART> detail part

Partition 1
Type  : 0B
Hidden: No
Active: Yes
Offset in Bytes: 65536

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
* Volume 4     E   NEW LABEL    FAT32  Removable    953 MB  Healthy

DISKPART> set ID=AF

DiskPart successfully set the partition ID.

DISKPART> list part

  Partition ###  Type              Size     Offset
  -------------  ----------------  -------  -------
* Partition 1    Primary            953 MB    64 KB

DISKPART> detail part

Partition 1
Type  : AF
Hidden: Yes
Active: Yes
Offset in Bytes: 65536

There is no volume associated with this partition.

I hope this is helpful.

  • I see the asterisk next to Partition 1, yet when I use the command delete partition I get the error "there are no partitions selected". – wcoenen Jun 4 '14 at 20:41
2

I had the same problem with the partition being listed with asterisc (selected) but could not select it and I had the no partition selected problem and after reading the solutions here and in other places I removed the partition with clean and then re created it and made it active and then formatted the drive again in Disk Management. I still do not know yet how to put system on it to make it bootable

I did

DISKPART> clean

to clean the partition... Then I used

DISKPART> create partition primary size=14366

( I got that buy doing 14(GB) *1024=14366 MB) and then I listed the partition

DISKPART> list partition and it listed the partition with asterisk like before and then I just made it active, without selecting it again and it worked

DISKPART> active

then I formatted the partition in the disk management in windows 7 (but I did not get the option of making the partition bootable) and then on checking the status again I got Healthy (Active Primary Partition) I hope this helps

1

I was trying to do something similar so this may help you:

I wanted to select the partition so that I could then delete it. This was necessary so that I could then use the windows version of dd.

I was not able to select the partition with the asterisk. I tried selecting another disk and another partition, but as soon as I selected the target disk again the partition 1 was auto-selected with the aterisk. Since all I wanted to do was delete the partition, I was able to use the clean command within diskpart, so something like this:

diskpart

list disk
select disk 4 
clean

If you then run detail disk you will see that the status has changed to "unusable". I was then able to run my dd command from an image to this sd card.

0

Do you get the list disk process as Geoff Duke said ? If you don't than I think there might be some problem with your hardware , And then again if you do then try selecting again and check for typing mistakes this happens a lot with me . Also if still nothing happens go to explorer and format directly from there and come back again and try with cmd.

Not the answer you're looking for? Browse other questions tagged or ask your own question.