This is the effort to recover a failed hard drive containing several important research works. To sum up: with the method I tried (described below) I could not resume failed multiple images created using dd. Is there any suggestions or explanations on what went wrongo? Even suggestions for "google keyword" will help. Thank you very much.

I saw a post+answer on how to resume dd of a single image file here Can I resume an interrupted disk image done with dd? However, I must have missed something as the skip/seek options don't work for my case where I also split the image to multiple files. Below is the detail of my problem.

Source and destination drives are 1.8" HDD and 2.5" HDD, both connected via USB and are in NTFS. This is done in a virtual machine.

Following http://www.linuxquestions.org/questions/linux-server-73/dd-starts-fast-10mb-s-but-slows-down-after-30gb-2-4mb-s-658471/page2.html, I created the images using

sudo pv -ptreb -B 64k /dev/sde | dd bs=64k conv=sync,noerror | split -b 16384m - /media/target/whole-drive.img.

(buffer size 64kb and images are split into files of 16GB). One issue I noticed is even with the option "noerror" it stopped when encountered blocks it couldn't read, namely,

pv: (stdin): read failed: Input/output error=========================> ] 61% ETA 1:56:54 142GB 3:04:10 [13.2MB/s] [==========================================> ] 61%
2333629+1 records in 2333630+0 records out 152936775680 bytes (153 GB) copied, 11050.1 s, 13.8 MB/s

(This did not happened when the split option was not implemented - but it took too long time and it was not possible to wait so I cancelled and try to split images to small size hoping it would be faster).

At this point there are several images files (with extensions aa, ab, ...,ai).

With time constraint I could not start from zero again. So I tried

sudo pv -ptreb -B 64k /dev/sde | dd bs=64k skip=2333630 seek=2333630 conv=sync,noerror | split -b 16384m - /media/target/whole-drive.img.

The number of blocks 2333630 was calculated from 152936775680/655536 as the buffer size was 64k.

When I executed the above command, dd started from zero and I could not see any changes in the existing files at all (not even the time stamps). The remaining hard drive space does not change either. Please let me know what could go wrong.

Thank you very much again. Pawin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.