2

When I try to connect to my work VPN using OpenVPN, the connection fails with the message:

All TAP-Win32 adapters on this system are currently in use.

Many sources suggest to look in Control Panel\Network and Internet\Network Connections an enable the TAP adapter, but when I look there, there is none. Now I've run addtap.bat which is provided with OpenVPN, but I still don't get to see any TAP adapter, and logging in in VPN still fails. The output of addtap.bat is

C:\Windows\system32>"C:\Program Files (x86)\OpenVPN\bin\tapinstall.exe" install
"C:\Program Files (x86)\OpenVPN\driver\OemWin2k.inf" tap0801
Device node created. Install is complete when drivers are updated...
Updating drivers for tap0801 from C:\Program Files (x86)\OpenVPN\driver\OemWin2k
.inf.
Drivers updated successfully.

I've Run As Administrator both the setup of OpenVPN and addtap.bat. I've run deltapall.bat to remove any (maybe hidden) adapters. It said it removed three of them, after which I ran addtap.bat again to try to create another one. I also run OpenVPN itself as administrator. What's wrong?

Running Windows 7 Home Premium on a HP Pavilion dv7 4050ed. It has worked before, but I recently had to reinstall my laptop, for which I used the restore disks I created when I just got it. Everything else seems to work fine.

== UPDATE ==

The TAP adapter is found in Device Manager, but apparently it is disabled because it is incompatible with Windows 7 64bit. I've deïnstalled OpenVPNGui, downloaded a version that should be 64bit compatible, and installed that. Still no cigar. Then I found a tip to install OpenVPN (version 9) after installing OpenVPNGui, because that installs OpenVPN version 8. Now I got a v9 TAP driver in Device Manager, but it still doesn't work and shows up in device manager with an exclamation mark, and not at all in my network devices.

  • Apparently, TAP-adapter is not a tag? – GolezTrol Jun 3 '12 at 11:47
  • Not an answer to this issue perhaps, but on Windows 7 with OpenVPN 2.3.10 x86_64-w64-mingw32, running that addtap.bat script resulted in adapters that didn't connect properly, for me. After troubleshooting for a while, I tried manually executing the "devcon" command from the script, but specifying the OemVista.inf instead of the OemWin2k.inf file, and the resulting adapter worked immediately. – Peter Hansen Jun 8 '17 at 3:52
3

I was experiencing the same problem. What worked for me is to install the latest version of the OpenVPN GUI (openvpn-2.0.9-gui-1.0.3-install), reboot, stop OpenVPN, then install the latest version of just OpenVPN (openvpn-2.1.3-install) over the top of the original install. Make sure to do these installs with administrative rights.

The method is documented here: https://yeri.be/openvpn-windows-7

  • Thanks for your response. I managed to get it working before your answer by installing an older version, but I forgot to check back on the question. Anyway, I'm afraid to try your solution, since I've got it working now and I don't want to break it again. – GolezTrol Sep 19 '12 at 9:13
0

I forgot about this question, but I actually managed to get it working shortly after I posted it. I've installed OpenVPN various times and always with administrator rights, but it wouldn't work.

After a day of messing around I gave up, but tried again a couple of days later. That time I found a source stating that the latest OpenVPN could give trouble, so I installed an earlier version (still in the 2. range). That apparently did the trick.

-1

I make it work after I downloaded and installed tap-windows-9.21.1.exe. After then OpenVPN GUI bring up the TAP virtual adapter and established connection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.