I'm trying to set up a dedicated GRUB2 which (chain-)loads another GRUB on a disk with GPT partition table.

Relevant partitions:

  • /dev/sda1 BIOS_BOOT
  • /dev/sda2 BOOT (ext2)
  • /dev/sda3 FEDORA (ext4)
  • /dev/sda6 DEBIAN (ext4)

I installed Fedora first, using /dev/sda2 as boot partition. Then I installed Debian. The Debian installer recognized the Fedora installation and added it as boot entry, then installed its GRUB into the MBR. While this works for the moment, it's pretty messy, because every Debian update may change the boot config, removing the Fedora entry (tried it) and the other way around. That's why I want both systems to have their own boot loader and one main boot loader (that could reside on /dev/sda2), which loads one of them.

This is what I've tried:

  • Moved everything from /dev/sda2 to /dev/sda3/boot
  • Removed /boot mount point in Fedora (so /dev/sda2 isn't used anymore)
  • From a live Linux, installed GRUB2 to the MBR (grub-install --boot-directory=sda2 /dev/sda)
  • Wrote a menu.lst:
    • title Fedora
    • root (hd0,2)
    • chainloader +1
    • (Again, for Debian)
  • Converted that to a grub.cfg script (grub-menu2cfg or something like that)
  • When booting, actually got a GRUB2 menu with "Fedora" (and "Debian")
  • When selecting any one of those:
    • error: invalid signature
  • Issued "grub-install /dev/sda6" (and ...sda3) from all kinds of live Linux systems, all of which failed with another error message (in the case of the Debian installer, without explanation at all)
  • Added --force to the chainloader line, now it says "loading", then reboots
  • Found dozens of howtos, none of which seem to work for me

Forgot about this (rather extensive) question.

AFAIR I found and copied some files from another Fedora installation to get the boot loader working. In addition, I've created a symlink to the current Linux image and put that into the first/main GRUB config, so it'll always boot this particular Kernel.

I don't think this question is in any way valuable for someone with a similar issue, so it could probably be deleted.


I have a similar problem with an external SSD. It can be booted from the internal disk only. The system does not boot if the external disk is not connected.

I just found bootinfoscript and got some funny output (not relevant to be posted here) - but at least it's giving a clue that my thoughts and grub2 thoughts are totally different.

Maybe the tool is of help for you.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.