Today I was moving C:\Users to another partition using symlink junction method.

I had the great idea of making the symlink junction from C:\Users => U:\, instead of C:\Users => U:\Users.

Sadly, I've deleted the original "Users" folder and now, when I try to login, it says that The User Profile Service failed the logon.

Maybe I'm wrong, but this is because the root directory of user profiles isn't the system one, so now when I create C:\Users, I can't log into Windows and I get the above error message.

How can create a new C:\Users directory and workaround the problem?

Thank you in advance!


Problem seems to be that your C:\Users is either empty or unreadable. There should be service accounts (with their registry files) and user accounts (with personal registry files) and default skeleton account for new users. I remember that some older Windows version (was it XP?) screwed up system registry (at least user id's) if there is anything wrong with user registry files. This case is easy to find out as after that ACL management window shows only user ID's but not names in user list.

If you still have profiles at U:\ then try to just move them back to C:\Users\. Initially you could give C:\Users\ full permissions to everyone, it should work after that.

However, user folders contains permissions (in their ACL's) that is inherited from parent and that parent (originally C:\ and C:\Users\) is now killed so you may want to check those permissions after system is working again.

Another thing that you may want to use is junction when you want same files/information appear in two folders. At least it worked very well in similar situations. Yes, symlink may also do but I'm not going to recommend it because I have not had situation that requires symlinks (read: I have no experience with ntfs symlinks).

  • @Mike Boot with some live linux dvd/pendrive or maybe go with Windows installation dvd's recovery console. – Sampo Sarrala - codidact.org Jun 3 '12 at 23:48
  • the dvd recovery option might work, but linux does not mount NTFS as read-write – Mike Pennington Jun 3 '12 at 23:57
  • @MikePennington just while I write this comment I am working in Linux environment and there is read-write mounted Windows 7 NTFS filesystem from VirtualBox VDI's (through qemu nbd) and few others (read-write too) from my real Windows installation configured for dual booting with Linux... See linux.die.net/man/8/mount.ntfs-3g also and you will see that it is supported very well, I'd say completely. – Sampo Sarrala - codidact.org Jun 4 '12 at 0:01
  • linux has mounted NTFS as read write for years - and NTFS3G (the current userland driver) on occasion manages to access NTFS drives windows won't. Almost all mainstream livecds have it as well. – Journeyman Geek Jun 4 '12 at 1:00
  • @Sampo Thank you for your points. Actually I've tried to create the whole C:\Users using the Windows 7 setup recovery console, but I got no luck on getting this working again. Maybe the best solution is a system restore to some point, but I'm very sad because I was creating a W7 installation to make a disk image backup in order to have a "free of crap" thing (6 hours of my life... a total waste of my time). – Matías Fidemraizer Jun 4 '12 at 6:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.