I'm trying to install umlet. I have tried quite a lot of different configurations, but none worked. Whether trying from the .jar itself (java -jar umlet.jar), whether using it as an eclipse plugin, or even trying wine umlet.exe, it always fails to load. I think it might be caused by java itself, though I'm not sure. I have tried both openJDK and the legacy java, but none worked.

java -version returns openJDK 1.6.

From Eclipse, the error returned is:

Could not open the editor: The editor class could not be instantiated. This usually indicates a missing no-arg constructor or that the editor's class name was mistyped in plugin.xml.

From java -jar umlet.jar, the error is:

23 | ERROR | com.baselet.control.Main - "Initialization or uncaught outer Exception"
at java.awt.HeadlessException
[at ... etc...]

From Wine, the error is

wine: Install Mono for Windows to run .NET 2.0 applications.

I am looking for any solution that would make that software work.

  • Which version of ubuntu? Have you tried oracle javac? Have you tried sudo apt-get install umlet? Have you installed mono?
    – Tachyons
    Jun 4 '12 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.