14

Problem

My Dropbox context menu is missing in OS X Snow Leopard (10.6.8). While the Dropbox service runs normally, Finder doesn't show the icons and also doesn't give me the ability to browse files on the website or copy the public link.

What I've tried

  • Removed ~/.dropbox and ~/Dropbox/.dropbox.cache
  • Reinstalled Dropbox.app (both 1.4.7 stable and 1.5.0 experimental), went through the setup again
  • Restarted Finder
  • Logged out and back in
  • Removed /Library/DropboxHelperTools entirely, upon which the installer required me to enter the password and recreated the folder
  • Manually run /Library/DropboxHelperTools/DropboxHelperInstaller, results in this console output (also with sudo):

    <pid>28642</pid>
    usage
    <failure> 22
    
  • I know now that Dropbox hacks the Finder to insert these icons and context menu items, based on the FinderLoadBundle architecture (similar to this), but manually running the executables inside FinderLoadBundle.tgz under Dropbox.app » Contents » Resources doesn't do anything either.

All of these I've done over and over again, in random permutations.

I've made sure that

  • Dropbox appears in the Login Items under my Account (and I've never touched that)
  • Folder Actions Setup is enabled under Keyboard Shortcuts » Services.
  • Everything works fine on a newly created user account.

In any case, I can't get the icons or the menu to appear.

3
  • No problem, hope someones comes along with a proper answer.
    – Hassan
    Jun 9, 2012 at 22:27
  • If you create a new account on your Mac and log into that, can you get it working there?
    – Spiff
    Jun 10, 2012 at 0:51
  • Unfortunately, yes, @Spiff. I have no idea what I did to Finder though that makes it refuse to add these icons.
    – slhck
    Jun 10, 2012 at 7:08

5 Answers 5

5

In this thread, the person reported that Context menu is shown upon restarting the computer. can you please try that?

of course after install/reinstall :-).

3
  • You know what? That actually worked. I have no idea what service could have been related to this that would not have been restarted with a simple login/logout. It seems I just got used to not having to restart my computer every now and then like I used to do with Windows.
    – slhck
    Jun 16, 2012 at 16:01
  • ya, i was also forgetting that a restart may be needed for such cases but recently i've installed some WiMAX modem drives that also required me to reboot :(. however, nice to know that it worked for you. Jun 16, 2012 at 17:27
  • This is a link only answer. Can you include the relevant sections from your link?
    – Burgi
    Feb 26, 2020 at 11:18
5

Common fix to missing contextual menus in macOS: Confirm that the "Folder Actions Setup..." service is enabled in System Preferences.

System Preferences -> Keyboard -> Shortcuts -> Services -> Files and Folders. Make sure "Folder Actions Setup..." is enabled. (This has worked since Mac OS X 10.6.8, tested again in macOS 10.13.6)

Original info source: https://forums.dropbox.com/topic.php?id=16490&replies=18#post-104122 (link is now broken)

NOTE: This step was already attempted by the OP, as indicated in their initial question. I'm including this answer anyway, since taking this initial first step is what instantly brought back my Dropbox contextual menu (and others). It could be a helpful first step for someone else missing their context menu, so I request my answer to be left in as a quick reference for future user queries.

3

I had the same problem and found that if I quit and restarted the Dropbox application it would work again.

I found that sometimes I would reboot/log out and in and it would work, other times a reboot/log out wouldn't help.

1
  • I just restarted the app and it worked, my options came back in finder.
    – swt83
    Sep 15, 2014 at 16:42
2

Definitively, Dropbox was the problem. This work for my on Mac OSX Snow Leopard and Lion.

  1. Go to Preferences > Keyboard > Keyboard shortcuts
  2. Look for Services then Files and Folders
  3. Probably "Folder actions setup..." will be enable. Uncheck it, then close Preferences and force quit Finder
  4. To force quit Finder press Opt+Cmnd+Esc, select Finder then Relaunch
  5. Go again to Preferences and repeat steps 1 and 2, then check "Folder actions setup..." in order it be enable again.
  6. Close Preferences and Force quit Finder again.
2
  • Doesn't work any more on Mavericks to disable Dropbox ugly context menu:( Ho to disable it now?
    – Dmitry
    Nov 11, 2013 at 14:34
  • It worked for me. I was able to get "Move to Dropbox" back.
    – Azat
    Jul 26, 2018 at 17:31
0

Simply relaunching Finder brought back the contextual menu items for Dropbox. My method: Option+click on the Finder icon in Mac Dock and select Relaunch.

It's too bad that Desktop Dropbox has been "dying" this way for me for the past couple weeks. A recent upgrade to Dropbox? A glitch introduced by my upgrade from Sierra to High Sierra?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.