I'm trying to install Windows 7 on my computer and am continuously getting the error code 0x80070570 when installation gets to around 77%.

I have tried using around 7 DVDs of the 64-bit version, all showing the same problem.

  • I would have tried Googling the error code in honesty... – ThunderToes Sep 23 '14 at 8:45

Start the install, let it go to up to 50% or something like that (before it reaches the critical 77%), and then cancel the install. It should take you back to to Install Now screen. Then start the install again. The installation should work now without any errors.

You may also want to disconnect any unnecessary hardware from the system before starting the installation. This includes any USB peripherals, including but not limited to:

  • printer
  • scanner
  • microphone
  • external disk drive(s)
  • USB flash drive

You basically want to disconnect everything except the keyboard and mouse which is necessary for the installation guide. This may also include:

  • video cards
  • graphics cards
  • network cards
  • secondary internal disk drive(s)

Of course, not all of these components may be applicable to a laptop computer. And for a desktop installation you don't want to disconnect the internal disk drive on which you actually want to install Windows on. This is the only disk drive you want to be connected to the system during the installation.

  • i will try this and report back if i find any more errors – kira Jun 4 '12 at 12:14

I have also found this and other errors when Using the format and partition tools in the Windows 7 setup. I always install to an "unallocated" partition during setup, I delete the partition I wish to install W7 on, the makes it an unallocated partition, then I hit the Next button to install on that unallocated partition without prior formatting.

Other things that can cause installation issues

  • A faulty ISO downloaded from Microsoft or other source.

  • A faulty boot DVD (either due to the DVD itself, DVD writing software or the actual writing process).

  • Bad Memory Module(s) or other hardware

  • Sata driver issue, some bios's you can disable AHCI or set to compatibility mode prior to W7 installation.

  • well the dvds worked absolutely well with other comps, so lemme try out the other options u have said – kira Jun 4 '12 at 14:47

I had the same problem and discovered that the issue was caused by bad RAM. I fixed it by removing a stick from the second slot and using only the other one.


I spent a few hours banging my head against the wall with this error. I will summarize all the suggestions the 'net in general suggested, which also mirrors what I tried:

  1. Change IDE/AHCI/RAID mode in Bios
  2. Updated the BIOS to the latest version
  3. MemTest and/or replace and/or remove RAM sticks
  4. Try a different DVD drive
  5. Try a USB install versus slow-burned DVD
  6. Try installation to a different hard drive
  7. Try Windows 8 and Windows 7

None of that worked, and I always got the same error consistently... until I installed a 32-bit version of Windows instead of the 64-bit versions that I had been trying. It doesn't seem to matter if it's Home Premium, Ultimate, etc., but for some reason my machine (a few years old Dell) doesn't like the 64-bit install. I end up losing access to about 750mb of RAM, which is irritating, but this installation nightmare is now over.

  • Are you sure you don't just have a 32 bit system? 32 bit Intel Core CPUs were sold until 2008 or so. – Daniel Beck May 28 '13 at 6:33
  • Yeah, in my case I have an Intel E4500 (Conroe). – Jason Jun 30 '13 at 21:00

protected by bwDraco Aug 9 '15 at 18:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.