3

I have a Samsung 900x laptop and I want to change it so that when I close the lid, nothing happens (I often close the lid to carry it somewhere 10 seconds away, and by putting it into suspend it cancels any active downloads/etc).

Easy, right? Go to Power Options and change it there; just like on every other laptop in the world.

Not so fast:

enter image description here

Saywhat?! That message only shows up for the nodes for Lid Close Action, Power Button and Sleep Button. I can change every other setting except for those three.

I'm definately an Administrator on the computer, and I've googled the error and found dozens of hits on other crappy forums, but of course nothing on those worked (otherwise, I wouldn't be here). And as ususal the "Why can't..." hyperlink gives no useful infomation what so ever (just a generic Help document).

So - how can I change what closing the lid does? I will modify the registry directly if I have to.

  • Which version(Home basic, Ultimate or Premium) of windows is it? – avirk Jun 5 '12 at 5:14
  • Windows 7 Professional – Mark Henderson Jun 5 '12 at 5:15
  • `HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings` See if there are 15 reg key under it. – avirk Jun 5 '12 at 5:18
  • One more thing you can try is that go to device manager and uninstall the battery driver and then reboot may be it can fix this. – avirk Jun 5 '12 at 5:24
  • Have you tried those option already as you have not respond back? – avirk Jun 5 '12 at 5:33
4

I had the same problem and just found the answer here. http://answers.yahoo.com/question/index?qid=20110328121602AAFxtHH It worked for me. =]

There's this little program that by doing its work, cancels our options on what closing the lid etc do. It's called Fast Start. Run it, turn it off and now you have a fuller command of your laptop. Hope it works for you as well.

  • +1 for explaining an otherwise link-only answer, what many new users often fail to do. Remember that link-only answers aren't very useful and can become useless altogether if the link becomes invalid, so you've helped ensure the long-term usefulness of this answer. – bwDraco Sep 24 '12 at 5:41
1

My Samsung N150 has a program called Fast Booting SW that seems to be responsible for this problem. Disabling it solves the problem for me.

0

Please change the plan right now you are having Samsung Optimized and it is like a default setting. You can change it then you will be able to change those settings. I hope this will work if it doesnt then please provide more info.

  • It is currently set to Samsung Optimised. Although it doesn't matter which plan I set it to, the same thing happens. – Mark Henderson Jun 5 '12 at 2:21
  • It once happened with my dell laptop and I reinstalled the OS to solve this problem – NewUser Jun 5 '12 at 2:26
  • This is a brand new laptop that is running the factory image, so I don't think that's going to help in this situation. Sorry. – Mark Henderson Jun 5 '12 at 4:46
0

Just right click on start menu and click properties and then in the "start menu" tab you will find Power button option. Change it there and it changes. I don't why it started doing that? I tried changing it to sleep in power options like we normally do but for some reason the setting here overrides it. Earlier by power button was set to sleep. It automatically went to Hibernate. After googling I decided to go and see if there were option in the start menu and there was!! I don't why this happened but here is the solution P.S. Now I remember it happened after the latest Windows Update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.