28

No matter that

  • in SettingsBasicsOn startup, I have selected Open the home page
  • Home page is set to my internal address

Chrome still opens with two tabs: my Home page and a Sign in tab (in foreground!).

How do I disable this Sign in thing? I do not ever want to use it.

The version I'm using is Chrome 18.0.1025.168. (For purposes of testing, I'm intentionally using older version.)

  • 1
    On the Sign In page (under the form with credentials) there is a link to skip it. Once pressed, the Sign In page does not show up again on next start-ups. – Stan Oct 23 '14 at 13:35
21

Open the "Preferences" file from your profile* and edit the "sync_promo" section. This might look something like:

(...)    
   "sync_promo": {
      "startup_count": 6,
      "view_count": 4
   },
(...)

In this section, add "user_skipped": true (don't forget the comma at the end of each line that is not the last in the section), like:

(...)    
   "sync_promo": {
      "user_skipped": true,
      "startup_count": 6,
      "view_count": 4
   },
(...)

Find the information in this YouTube video. So, thanks to Vlăduţ Frăţiman.

  • profile path: open chrome://version/ or C:\Users\user-name\AppData\Local\Google\Chrome\User Data\Default\Preferences in Windows 7. You can use Notepad to edit it.
  • 1
    Make sure Chrome is closed before you edit the file. Otherwise your changes will be overwritten when Chrome closes. – Ian Dunn Jan 12 '13 at 20:36
  • The sync_promo line should look like this: "sync_promo": { "startup_count": 1, "user_skipped": true – user239032 Jul 18 '13 at 16:18
  • Some (deleted) answers suggest one might also need the same line in a "sync" section. Like "sync": { "user_skipped": true, "suppress_start": true }, "sync_promo": { "startup_count": 3, "user_skipped": true } But I haven't tested that. – Arjan Jul 20 '13 at 12:55
13

in SettingsBasicsOn startup, choose Open the following pages and put this link

chrome://newtab
  • Simple but effective. Thanks – skan Mar 9 '13 at 19:54
  • 1
    Way easier than the upvoted answer, and apparently just as effective. – krispy Nov 28 '15 at 16:17
  • 2
    @krispy - But only works if you want static home pages. For me I want it to be where I left off without the annoying additional page. – Martin Smith Oct 16 '16 at 15:09
  • @MartinSmith - very good point – krispy Oct 19 '16 at 15:07
4

This has been bugging me for a while and it appears Google is encouraging people to sign in.

I needed to make another tweak for anyone who has had this problem recently.

Script before:

"http://www.google.co.uk/" ]
   },
   "sync": {
      "suppress_start": true
   },
   "sync_promo": {
      "startup_count": 3,
      "user_skipped": true
   },

Script after fix:

"http://www.google.co.uk/" ]
   },
   "sync": {
      "user_skipped": true
      "suppress_start": true
   },
   "sync_promo": {
      "startup_count": 3,
      "user_skipped": true
   },

Works for me.

  • 3
    Please don't write anything chatty like "Google wants to have our data for their big plan". Just answer the question. Please read help center before answering or asking. Thanks. – user 99572 is fine Jul 20 '13 at 11:52
  • (Hmmm, @user99572isfine, as for your suggested edit: I wanted to hit "improve" to also get some code formatting in there, but clicked "approve" instead. I guess you cannot edit either at this point?) – Arjan Jul 20 '13 at 12:39
  • Actually, this seems to be a comment to prometoy's answer. When reading the suggested help, you'll see you need just a bit of reputation to be able to comment next time. – Arjan Jul 20 '13 at 12:42
  • More like browbeating people into submission by interrupting their workflow every ~ 30 mins. The best solution is to switch browsers as they keep changing the setting name to push new ways to get this tab in your workflow again. – G_V Jun 18 '18 at 12:26
3

Sometimes sign in page appears at every startup because you installed an extension that needs to communicate with your google account.

for example "Google Keep" ask you to sign in because it saves favorite links in your google account.

It is better to first check installed extension. chrome://extensions

  • yes google keep – osman Dec 21 '18 at 10:05
2

Just click on the "No, thanks" link at the bottom of the sign in page.

  • This worked for me. I don't know why you should open any file and skript around within... thanks – Neifen Sep 18 '15 at 13:52
  • 1
    I don't see any such option i.stack.imgur.com/fgFje.png – Martin Smith Oct 16 '16 at 15:10
  • Google removed this option and instead chose to make the browser useless by having it interrupt your workflow every few minutes. – G_V Apr 8 '17 at 9:23
1

Run chromium-browser --bwsi to "browse without sign-in" and disable it.

  • OP is running chrome. Does this also work with vanilla chrome? – Jeremy W Jun 23 '12 at 12:02
  • "...and disable it."? The Q is that I don't know how to disable it. – Alois Mahdal Aug 16 '12 at 13:54
0

You can go to settings --> Privacy and security --> Allow Chrome sign-in and disable it.

But notice: with disabling that option, your chrome will not sync your data such as history and saved passwords anymore!

New contributor
Hamidreza Ahmadi is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.