I have a WD My Passport 650GB (with Firewire and USB). I'm using it for almost a year now and it always worked fine. While underway I simply plug it in via Firewire - at home I connect it to my Airport Extreme to have it available as a network storage.

Today I connected the HDD to my MacBook Pro (via firewire) and NOTHING. The HDD is starting (clearly making a sound and the power-indicator is flashing) but it won't appear in Finder. I also tried it with USB - no sign.

I ran Disk Utility and tried to repair the disk. At first try I got a red error line saying that something is wrong with the "headers". However the repair completed with a success message saying that everything is OK. I also verified the HDD. Also with a success message. I did that a few times again and unplugged it in between. Never got the error with the headers again - it's always completing and saying everything is OK. However I can't mount the drive.

That is what Disk Utility is showing.

enter image description here


Try mounting the volume at root level with terminal. You may also want to check the integrity/health of the drive with tools such as Drive Genius. I would just do a data rescue on the drive and reformat the it to save time, provided you have the tools and storage to hold your recovered data.

  • Thank you. However I might need help with mounting my harddrive with terminal. I found this post support.apple.com/kb/TA23941 where it is explained step by step. However once I get to the last step and run sudo mount -t hfs -o rdonly /dev/disk2s3 /Volumes/My Passport terminal always outputs the message usage: mount [-dfruvw] [-o options] [-t external_type] special node mount [-adfruvw] [-t external_type] mount [-dfruvw] special | node So somehow I might call the wrong params or so when trying to mount the drive. Any ideas on that? – Matt Jun 6 '12 at 8:11
  • the commands i use would be "diskutil mount /dev/disk0s2" *please note you may has to list the volumes to find out if your hard drive is recognized as "disk0s2" as it may change depending on what other volumes are mounted. Through 'diskutil' you can repair the disc etc. much like disk utilities which you have used but at root level. Also i would do a filesystems disk check, eg. "fsck_hfs -f /dev/disk0s2" again you'll need to verify the name of the volume, you may use this command "df -hl" – Lachlan Jun 6 '12 at 8:32
  • Well, my diskname would be disk1s3. If I run diskutil mount /dev/disk1s3 terminal says Volume on disk1s3 failed to mount … If I run fsck_hfs -f /dev/disk1s3 terminal says The volume My Passport appears to be OK. Any ideas? – Matt Jun 6 '12 at 8:42
  • this is very strange, could you list all details of the drive, eg. hows it formatted, has it ever played up before, is it used on more than one machine, is it used on different OS, do you safely eject the volume etc.. I had a problem like this once, cause windows was being difficult and did something to it and when i used it on my mac it would not mount, put it back on the windows machine, recognized it, put it on mac, fixed issue – Lachlan Jun 6 '12 at 8:45
  • Disk Utility says the format is Mac OS Extended (Journaled). I do actually have it plugged into my TimeCapsule and I use it normally as Network Drive. However I got a new usb hub and unplugged the device from the TimeCapsule and connected the drive to the new hub instead of directly to the one and only usb slot on the time capsule. I tried it and everything seemed to work. However on the same evening I wanted to browse the external drive through my network and I couldn't access it - so I unplugged it and now I'm trying to fix it. Right now it's plugged into my mac directly. – Matt Jun 6 '12 at 8:57

I just debugged a practically identical issue. After hours of trying various stuff, I finally found an answer, after closely examining system.log in Console. I found this:

3.1.13. 21.42.42,090 sudo[622]:    ... : TTY=ttys001 ; PWD=/Users/...; USER=root ; COMMAND=/usr/sbin/diskutil mount readOnly /dev/disk2s2
3.1.13. 21.42.42,000 kernel[0]: jnl: disk2s2: is_clean: journal magic is bad (0xdead00ab != 0x4a4e4c78)
3.1.13. 21.42.42,000 kernel[0]: hfs: late journal init: volume on disk2s2 is read-only and journal is dirty.  Can not mount volume.
3.1.13. 21.42.42,000 kernel[0]: hfs_mounthfsplus: hfs_late_journal_init returned (22)
3.1.13. 21.42.42,000 kernel[0]: hfs_mounthfsplus: encountered errorr (22)
3.1.13. 21.42.42,000 kernel[0]: hfs_mountfs: encountered failure 22 
3.1.13. 21.42.42,000 kernel[0]: hfs_mount: hfs_mountfs returned 22

The issue seemed to be with bad journal. So I disabled journaling and the mount then worked just fine. Afterwards I enabled journaling again, all fine. I'm surprised that Disk Utility was not able to detect this during Verify Disk (which reported that all is fine).

Terminal option to disable journaling is:

sudo diskutil disableJournal force /dev/diskXsX

with diskXsX replaced to whatever is appropriate for your case. This command above will report error at exit, but just ignore it.


This happens to me sometimes when I unplug the drive without ejecting it first. Just plug the drive and don't do anything. It will show up again in Finder after waiting about 10 to 15 minutes.

My guess is that the OS has to re-index the entire drive if it weren't properly disconnected. That takes some time. Also, my drive is formatted with exFAT and that could be one of the reasons.

  • Alright, I might give it a try. However to index my entire 400gb it might take longer than 15min I guess. I was able to read the drive on windows now, which is kind of a relieve. If it would come back alive in Finder and on my Mac - do you think I could use the drive furthermore or is it buggy? – Matt Jun 6 '12 at 10:57
  • Ok, this might not work, because the drive automatically goes into a kind of standby mode after a few minutes. I don't think it's going to be indexed when the drive is not running!? I'll just back up the files on the old pc in my house since it's working there and than I'm going to format it completely. – Matt Jun 6 '12 at 11:48
  • Unfortunately I have no way of knowing if the problem is the same as yours, I'm just telling my personal experience. My drive is a 500 GB WD Passport and I plug it to the USB port. I had this a few times already and it always comes back eventually. It might take longer than 15 minutes (but no more than 30 in my case - it might depend on how many files you have there). It also scared the hell outta me the first time, now it's just annoying. – djeidot Jun 6 '12 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.