I have a file named aes_demo.vmdk that I received from someone who did some contract work for our company. I can no longer get a hold of that person. It is a Linux Ubuntu hard drive file for VirtualBox. I need to set it up so I can run it and get into the virtual machine. Here is the setup screen shots:

enter image description here enter image description here enter image description here enter image description here

The computer I installed VirtualBox on is Windows 7 64-Bit. The version of VirtualBox I installed is 3.2.10-66523. Once I setup the virtual machine I try to start it. I get the below screen. Shouldn't it boot into the computer and show me the Ubuntu desktop? What might I be doing wrong?

enter image description here


I have tried the following in Grub to see if I could get it working. Oh, I did try the below as a SATA, SCSI, and IDE drive. They all ended the same.

enter image description here

When I boot from the Grub prompt it appears to be working. Then I get the following error message:

enter image description here


Ok so what i think is happening is that the virtual machine is finding the grub bootloader which is then unable to boot any further because it cant find either the kernel or initramfs.

0st, make a backup of your virtual machine files incase something goes to Belgium.

1st, be sure to check the hard drive settings to see if the image is looking for a virtual sata or ide drive.

2nd, if the first option provided no joy, within the grub prompt you can do some things that may help, this article explains it a bit, http://sazeit.com/articles/boot-ubuntu-from-grub-prompt.

3rd, boot into the machine using a livecd from the distro and repair the boot-sequence from there.

once you have got things booted you may want to reinstall grub, onto the drive, something like,

grub-install /dev/sda

| improve this answer | |
  • Actually, I remember that the consultant also gave me a AES_Demo.ovf file. Could it be that the aes_demo.vmdk file won't work without it? Or that the aes_demo.vmdk file might be compressed? – Linger Jun 5 '12 at 13:31
  • The ovf file should describe fully the virtual machine hardware, when you import the files into virtualbox, i believe you need to select both the vmdk and ovf files. i am not a virtualbox expert but i believe that you could try the "appliance import wizard" option and then select both files at that point; and it will then pre-populate all the settings required to run the image. – joe Lovick Jun 5 '12 at 13:44
  • good tip on #3, it will give you a good show of the vm disk filesystem. you can mount it's contents (assuming fdisk -l shows the device as sda) via sudo mount /mnt /dev/sda1. – invert Jun 5 '12 at 13:46

I would try to restore brub from the command line after you have backed up your VM image

Type "find /boot/grub/stage1". You'll get a response like "(hd0)" or in my case "(hd0,3)". Use whatever your computer spits out for the following lines.

Type "root (hd0,3)".

Type "setup (hd0,3)". This is key. Other instructions say to use "(hd0)", and that's fine if you want to write GRUB to the MBR. If you want to write it to your linux root partition, then you want the number after the comma, such as "(hd0,3)".

Type "quit".

Restart the system.

| improve this answer | |
  • when I use find and setup I get the unknown command message. – Linger Jun 5 '12 at 14:33

Usually VmWare has hard disks managed by a SCSI interface. You might get slightly different device name in a SCSI environment than in a SATA one.

What I would do, in the storage option of the VM setings, I would detached the vmdk from the SATA controller, I would add a new SCSI controller and attached the vmdk to that one. You can remove the SATA controller.

Then I would boot the VM.

Note: I had the exact problem when importing a Suse Linux Entreprise Server VmWare vmdk file in VirtualBox. I had to map it to a SCSI device to work.

| improve this answer | |
  • I tried SCSI, SATA, and IDE and none of them work. – Linger Jun 5 '12 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.