9

Firefox 13 (Released June 5, 2012) has introduced a new default setting to Load Tabs on Demand. This causes the browser to only restore the currently selected tab when resuming a session on startup, after a crash, or on a requested reload. I really don't like how I now have to click each tab and select restore.

How can I turn this off?

1
  • 1
    New question for Firefox 47 here.
    – Sparhawk
    Commented Jun 9, 2016 at 2:44

3 Answers 3

11

You can turn off the new default setting within the options panel.


  • Open the Firefox menu by clicking the Firefox button

Firefox Menu Button

  • Select Options

Firefox Menu Loaded

  • On the General Tab click the option drop-down next to When Firefox starts: and choose Show my windows and tabs from last time

Firefox Options - General Tab

  • Uncheck Don’t load tabs until selected option and press OK

Firefox Options - uncheck load tabs

4
  • 6
    Starting with Firefox Aurora 16.0a2 (possibly earlier, I have not checked) the option has moved to the 'Tabs' page. So check there as well if you find your settings dialog different from the screenshots!
    – danielkza
    Commented Aug 8, 2012 at 20:45
  • 1
    What about newer versions of Firefox, with the completely redesigned preferences? I can't find it there and even setting browser.tabs.loadInBackground in about:config does not do it. Commented Jun 23, 2020 at 11:07
  • 1
    @FabianRöling, see superuser.com/questions/433096/…. Commented Mar 16 at 11:36
  • 1
    @RokeJulianLockhart Thanks! I already have that set, maybe that came from the "Load background tabs lazily" extension that I installed in the meantime. Firefox still seems to only load a limited amount of tabs automatically on startup, but I can use the "Add blocked tabs" button of that extension to add the rest to its queue, which the extension will load one by one, so it reduces load on the computer and makes the first page usable way earlier. Commented Mar 16 at 14:38
2

One small addition to Jeremy's answer is that after you've unchecked the checkbox, you can switch back to one of the other options in that dropdown and keep the setting.

This is useful for people that don't save their tabs by default in cases like restarts caused by extension installations where your tabs do get saved.

0
2

And if you're using Tab Mix Plus (TMP), you need to go to TMP Options > Session > Restore and check the "Reload all tabs" checkbox (which respects the Load Tabs Progressively add-on if you're also using it).

Not sure about what needs to be done if you're using the Session Manager add-on.

/kim

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .