I am having the seeming common problem of Widows Explorer not responding. I have tried autoruns and turned off everything recommended. I have run sfc /scannow 3 times and it comes back clean. Booting in safe mode it appears to work. I read somewhere that the problem could be a service program, but can't remember where I read it or how to do it. Something about turning off all service programs and then turning them back on one at a time. The problem is I don't remember what it said to do.

I have an HP desktop with these specifications

AMD quad core processor 1.8ghz
1TB and  500GB SATA hard drives
Nvidia 8400 graphics card
a 2mb internet connetion 
2 BD RW drives
Windows 7 
  • 2
    Which version of Windows (XP, Vista, 7, etc.)? – Bob Jun 6 '12 at 9:49
  • have you tried to take a look at programs running when it's not responding ? – nXqd Jun 12 '12 at 10:00

I would look for and disable un-needed Windows Explorer add-ins using ShellExView by NirSoft.

Only disable non-microsoft extensions. There may be some extensions that are providing functionality you want, or it might all just be slowing you down. You'll have to experiment a bit to find out if a shell extension is the issue.

  • you've heard the saying "best laid plans of mice and men". I am unable to run ShellExView because windows explorer decide to not respond. I'll keep trying. Thanks for the tip. – William Barnes Jun 13 '12 at 1:21
  • GOT IT THANK YOU. The culprit is cmdlineext_x64.dll. It came with Call of Duty IV as a piracy protection tool. Written by Sony in Austria. Once disabled WE seems to be OK. Call of Duty doesn't work but I'll deal with them on that. Again THANKS to all of you who responded. I learned lots of good stuff. – William Barnes Jun 13 '12 at 1:59
  • P Spoke to soon. WE worked great for about 12 tries and then hung up again. I did disable all drives except for C: and the original DVD RW. That didn't sem to help. – William Barnes Jun 13 '12 at 2:10
  • I am 90% sure that the problem is a Service Program. I stopped all of them and WE seems to be responding fine. I started adding them back 8 at a time to eliminate the problem. Is it possible that it is not any one SP but could be a combination of 2 or more? If it would help I can list the SP's. There are 26 of them 6 of them I am sure are not the problem because everything has been working fine for a day with those 6 running. – William Barnes Jun 14 '12 at 15:14
  • Hey William, run it from Task Manager. :-) – Warren P Jun 15 '12 at 19:41

After stopping all non-MS SP's and restarting them one at a time the culprit seems to be the Pure Networks Platform Service. It is a part of Cisco Systems and is used by Network Magic and Speed Meter Pro. It is loaded on my laptop with XP and no problems. I sent a trouble report to them and will see what happens. It's a shame because Network Magic does a pretty good job of managing and securing a home network without me having to become a network engineer.

Thanks for all the suggestions, I learned a lot from you folks and I appreciate it.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.