This is a very peculiar problem with a station on our network. The client pc is running Windows 7 Pro. What makes this problem interesting is that this client is the only node on the network that seems to be experiencing this proglem. When I try to ping a specific Win 08 server by host name, I get an IPv6 address and get General failure. But when I ping it's IPv4 address, it responds just fine.

My first thought would check the DNS server the name resolutions to see what would be going on, but the problem begs the quesion, why does the station get an IPv6 address back and fails as opposed to using the IPv4 settings (which are static btw). What gives? I am including a screen shot of trying the one specific server and failing while trying another server with success. All other nodes on the network don't have problems communicating with the server the one station is having issues with. Pingng: General Failure

  • 1
    probably firewall related. Can you disable that computers firewall to check? If this works, then maybe resetting defaults of the firewall might fix it...
    – Logman
    Jun 6, 2012 at 15:22
  • Firewall on the machine is disabled. Jun 6, 2012 at 15:33
  • Is the "IPV6 Protocol" enabled under network settings on the target machine?
    – Diogo
    Jun 6, 2012 at 15:50
  • @Diogo Yes IPV6 is enabled. Other machines on the network that are IPv6 enabled get ping responses via IPv6. Jun 6, 2012 at 16:02
  • Maybe you should set a static IPV6 address on target machine and test again, it could be happening due to a mask limitation, I mean, your sorce and target machines arent on the same IPV6 network. It is really weird, my next step would be installing a sniffer such as wireshark and debug each step of icmp ping request/responses...
    – Diogo
    Jun 6, 2012 at 16:07

12 Answers 12


In my situation, I found peerblock caused this.

Some applications block http traffic, peerblock for example. These cause pings to fail via the "General Failure" error message.

The way I found the application causing this was to kill processes one by one and checking the pings. Eventually I killed peerblock in my case and my ping started working.

If your pings are failing only for a few sites it most likely Firewall, Antivirus or some other HTTP interception/blocking application like Peerblock, Charles, Wireshark... etc.

  • though peerblock might have caused the issue in your case its not the generic answer, try modifying your answer to me more explanatory so that its helpful to future users
    – Shekhar
    Oct 28, 2013 at 19:32
  • @Shakehar I have amended my answer to try an be a little more generic.
    – Oliver
    Oct 30, 2013 at 12:53
  • In my case, a service belongs to DewVpn was causing all the trouble.👍
    – Ayub
    Jan 25, 2021 at 16:58

I had a similar issue. I had to uninstall the AnyConnect mobility client.

I had a constant ping running and was getting the "general failure." to; as soon as the uninstall was halfway done I was back to being able to ping.

  • 2
    I had a similar issue with AnyConnect. found out theres a setting in advanced -> preferences -> Allow local (LAN) access when using VPN (if configured) Sep 24, 2014 at 17:59

Found out through reading a couple of other posts that IPv6 is not exactly disabled by unchecking the protocal in the network adapter settings. Also, there's prefix policies built into windows that favors IPv6 over IPv4.

Turns out Microsoft has some tools that help with choosing presedence or choosing to disable IPv6 altogether on their site. Still not sure why I got the General Failure message in the first place, but at least I was able to fix the precedence using the Microsoft Fix it 50410 on that page (Prefer IPv4 over IPv6 in prefix policies).


I would get this error after:

  1. Accessing a site.
  2. Connecting to my corporate VPN.
  3. Accessing the same site.

It didn't happen for all sites, just sites that we (the company) published. To fix it, I ran

ipconfig /flushdns
  • Wow! Indeed, that did solve my problem! :)
    – Kounavi
    Apr 11, 2015 at 19:07
  • Until I read this, my only solution to the "General Failure" issue after connecting to a VPN was to disconnect, reconnect and try again. That often fixed it within one or two reconnects. Got fed up of having to do that, found this answer, and now will never have to do that again. :-)
    – daiscog
    Mar 23, 2016 at 11:10

It appears your computer has 6to4, an IPv6 transition/tunneling technology, enabled. Unfortunately 6to4 is very unreliable in practice and for many people it is completely broken.

It's a good idea to disable all of the transition technologies if you aren't actually using them, since they can all cause various problems such as this.

You can do so from an Administrator Command Prompt with the following:

netsh int ipv6 isatap set state disabled
netsh int ipv6 6to4 set state disabled
netsh interface teredo set state disable
  • What I don't understand is that 6to4 is something that I would configure in a Cisco router, never on a host. I can't believe MS even spent 2 seconds writing this. I bet it has never been used by anyone.
    – Brain2000
    Dec 6, 2014 at 17:54
  • @Brain2000 My guess is to cover enterprise use cases, " I bet it has never been used by anyone" who wasn't forced to by infrastuctural constraints
    – twobob
    May 8, 2017 at 9:23

the 'cybersec' feature of the nordvpn client also causes this for other (local) subnet ranges to not be reachable, even when vpn is OFF - $deity knows why - turn off the 'cybersec' option and all of a sudden your other lan subnets work again.

  • 3
    NordVPN also has a "Make computer invisible on LAN" option that will do exactly that. Even when NordVPN software isn't open or connected. May 19, 2019 at 18:21

In my case, this actually propagated all the way down to the Cisco VPN client. It said that there was a network subsystem failure. It turns out that my wireless nic was getting an IP address and all, but when I tried to ping my router, it was giving me a General Failure.

I took a look at device manager, and there were a bunch of new Bluetooth items that did not have their drivers installed. That was odd, because I hadn't installed anything new. In fact, this is a laptop with built-in Bluetooth hardware.

I know that Bluetooth allows you to do PAN (personal area network), so I wondered if this was somehow taking precedence over my WiFi NIC. I disabled all of these items in device manager, and although no new drivers were installed for this 'presumably new hardware', this allowed me to begin pinging my router. I'm now using my laptop successfully to both get on the we and VPN.


I also ran into a similar issue. Namely, I was unable to ping or tracert www.google.com on a Windows 7 operating system and it threw a General Failure.

I did the following to trouble-shoot and resolve issue:

  1. Issue command ping -4 www.google.com. This explicitly pings using IPV4. Did not resolve issue.
  2. Issued same command from #1, but ping -6 . Explicitly ping with IPV6. Error stated that it could not find host www.google.com

  3. Issued same command with different target (within my network) without issue.

  4. Temporarily stopped firewall (AVAST) and was successfully able to ping/tracert to www.google.com.

  5. Opened Avast Internet Security, clicked firewall settings on left pane, clicked Settings button.

  6. Clicked System rules and then enable ICMP (Internet Control Message Protocol ) to allow outgoing ping and trace request. Resolved Issue

Concerned: I issued the above commands on same workstation a few weeks ago without issue. I'm not sure how that setting was changed.

  • In case it helps anyone, I was getting a General Failure on Windows 8.1. Fixed by uninstalling McAfee bloatware that came with the Asus laptop. Apr 26, 2015 at 23:53

Fixed one of these on win 8.1 by resetting TCP/IP and Winsock. For anyone who needs info on how, open ADMIN command prompt and run:

Windows Vista, 7, 8

netsh i i r r

netsh winsock reset

Then reboot.

Windows XP

netsh i i r r

netsh w r

Then reboot. Good luck!

  • I had an issue with Ping givin' "General Failure" every time I started our C# app which uses sockets. The solution posted here fixed for me. Thanks
    – Dan
    Dec 27, 2016 at 15:39

In my case this happened because my Internet connection had both IPv4 and IPv6 enabled, but I then connected to a VPN that supported only IPv4. So I guess Windows was still trying to connect to that host over IPv6 over the VPN, which failed.

The fix was to disable IPv6 in the network adapter properties for my Internet connection.


You may need to reconnect to your VPN.

I ran into a similar issue, and tried flushing the dns cache (ipconfig /flushdns) to no avail, I ended up needing to disconnect and reconnect to my VPN to get resolution to start working once again.

Until I did that ping and tracert both failed (but I was able to lookup the host name via nslookup).


Note that you can ping a computer by hostname using IPv4 by simply supplying /4 switch to the ping command:

C:\Users\user>ping xxx.com

Pinging xxx.com [xxx:7789%24] with 32 bytes of data:
General failure.
General failure.

C:\Users\user>ping /4 xxx.com

Pinging xxx.com [10.xxx.xxx.196] with 32 bytes of data:
Reply from 10.xxx.xxx.196: bytes=32 time<1ms TTL=128
Reply from 10.xxx.xxx.196: bytes=32 time<1ms TTL=128
Reply from 10.xxx.xxx.196: bytes=32 time<1ms TTL=128
Reply from 10.xxx.xxx.196: bytes=32 time<1ms TTL=128

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .