I'm trying to establish a serial connection to a peripheral from my PC's RS-232 port. Pretty simple stuff, and I've had not trouble doing it with countless peripherals before. And yet when I configure PuTTY to the right baud rate, stop bits, etc. I'll type in "*IDN?", press enter, and the unit won't reply. After going over my settings over and over again, I decided to try another terminal program, Termite. This time it worked like a charm. What puzzles me, and what I'm trying to figure out by posting this question, is why Termite would work when PuTTY did not despite the fact that they both have the same settings.

PuTTY: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

Termite: http://www.compuphase.com/software_termite.htm

EDIT: I now tried Tera Term as well, and it works. So PuTTY is the odd one out.


Had similar problem,

I had to check in the settings under Terminal => local echo , force On

A bit too late but hopefully will help someone else.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.