25

I use gnome-do a lot and usually I summon it using [Super] + [Space]. It works just fine on my desktop PC (Linux Mint 11) but on my new ThinkPad T420 (Linux Mint 13) it didn't work that well. I had to either tap super or space twice to open the gnome-do popup. I quickly realized that this was happening due to the keyboard shortcut for menu (super / windows button). I don't need the menu shortcut for anything.

I already checked in Preferences -> Keyboard -> Shortcuts but there was no such setting as "Menu" or "Start menu" or anything like that. Where can I disable the keyboard shortcut for menu?

4 Answers 4

22

source

  1. Go to System Settings
  2. "Locales" (I think it's called that way, but I am note sure since I use a german version of Cinnamon)
  3. "Layouts"
  4. Select your keyboard layout and click on "Options" on the right
  5. "Alt/Win key behaviour"
  6. Change it from Default to "Hyper is mapped to Win-keys"

After performing these steps on Arch Linux with Cinnamon 1.4UP3-1, I was able to use Gnome Do again.

5
  • 3
    Awesome! That did the trick. I went Menu -> Preferences -> Keyboard -> Layout Settings and then steps 4-6. After that I had to log out and in to get it work.
    – miq
    Jun 26, 2012 at 6:41
  • 4
    Downvoted because this is not what is asked: it is not a matter of changing the mapping of Hyper to Win-keys, but a matter of avoiding the Hyper key (or the Win-keys) to be used in the shortcuts. The end result might be the same, but the process is not. In my case I do not want to change the behavior of the Hyper key, but I do want to avoid it opening the menu.
    – blueFast
    Jul 29, 2014 at 12:33
  • The settings dialog can be started by running "cinnamon-settings". Then Hardware, Keyboard (or type keyboard in the search), keyboard layouts, Options button (bottom right corner), then step 5 and 6.
    – basic6
    Dec 15, 2014 at 16:10
  • Can this be done programmatically? Dec 25, 2014 at 1:29
  • doesn't work for me. Feb 7, 2020 at 17:27
21

Here is a solution that doesn't require fiddling with system settings. Tested on Mint 14 MATE, but should work on Cinnamon too.

  1. Right-click on Menu icon on bottom left of desktop
  2. Click "Preferences"
  3. In the initial "Main button" tab, click in the field to the right of "Keyboard shortcut"
  4. Press a new hotkey combo (I chose ctrl+win+space)

Voila - there are now hotkeys for the menu as well as Gnome Do.

6
  • At list in Linux Mint 17 “Qiana” - Xfce (64-bit), that does not work: the default shortcut gets added again
    – blueFast
    Jul 29, 2014 at 12:30
  • 2
    Works for Cinnamon 2.4.5. This should be the accepted answer. Feb 3, 2015 at 8:37
  • @JonasWielicki The question was asked in 2012. There wasn't even Cinnamon 2.0 back then. I now have Cinnamon 2.0.14 and this answer doesn't seem to apply to it.
    – miq
    Feb 3, 2015 at 14:55
  • 1
    It seems to apply to 2.4.5. That is the version number my cinnamon reports in System Info. I’m on Fedora 21 fwiw and the answer applies for me. Feb 4, 2015 at 12:20
  • 3
    This is a great answer. I'd also like to add that if you really want to disable the shortcut entirely, press backspace when the UI is requesting a keypress. Aug 29, 2016 at 5:07
0

On Cinnamon on Linux Mint 13 (Maya) the "Active the window menu" shortcut (bound by default to Alt+Space) is under Menu -> Preferences -> Keyboard -> Shortcuts. Just click the relevant row to edit or disable the binding.

2
  • 1
    Thanks but I meant the Menu in the lower left corner (the "Start" menu), not the window context menu.
    – miq
    Aug 3, 2012 at 13:13
  • And can anyone tell me what symbols are recognized here? I managed to remove the old binding, but cannot get it to recognize any new one.
    – Luke H
    Nov 19, 2012 at 3:56
0

Left click Menu button Left sub-menu Down sub window

select shortcut for open close the menu

The previous solution prevent you to use ALT for creating shortcut

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .