3

when I try to run Ubuntu on Hyper-V virtual machine, it gives me this error and doesn't let me continue:

piix4_smbus 0000:00:07.0: SMBus base address uninitialized - upgrade BIOS or use force_addr=0xaddr

what exactly do I have set up wrong? i'm giving it a 64gb hardrive with 1024 startup ram and 512mb - 4096 dynamic ram. If you need more information, please let me know how to find it as i'm just starting out using this.

1

I had the same error trying "Ubuntu 12.04 Desktop 64 bits" on Hyper-V 2008 R2 when chosen to just try Ubuntu.

  • First ensure your Hyper-V is up-to-date.
  • Then install Ubuntu basically in your VM but don't choose to run installation updates
  • Next time you will run its updates. SMbus bug will fixed. Worked for me.
0

Not sure why this happens, but I can confirm this worked for me using Ubuntu 12.04.2 on Hyper-V.

Basically, they are instructions on disabling the i2c_piix4 module.

  • 1
    Do you know what the effect of disabling i2c_piix4 is? What is it needed for? – CMCDragonkai Jul 16 '14 at 5:10
0

It happened to me today. I installed Ubuntu 18.4.2 LTS and I got that error. I waited a few seconds and then it just continued.

I am using Hyper-V Core 2012 R2 with latest updates. I have 2 dual core Xeon processors with an old Motherboard. I was worried about the BIOS not supporting it.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.