Possible Duplicate:
Windows 7 delayed file delete

Lately I have this problem regarding deleting EXE files on my Windows 7 installation.


  • I am an administrator on this computer.
  • The file is not locked by any process. (checked with Unlocker)
  • The program (exe file) is not running in the background.
  • There aren't any file system inconsistencies. (checked with CHKDSK)
  • There are no bad sectors on my hard drive.

Problem: Whenever I try to delete an exe file, the deleting process completes successfully, but the file won't disappear from Windows Explorer (tried also the cmd, the file is still there). Whenever I do a software upgrade (which needs to replace an exe file) it finishes with an error: "Can't replace file xyz.exe".

The idea is that the file will disappear after 1-2 minutes after being deleted.

I'm a developer and I can tell that building a source code drives me mad, because the exe file can't be replaced by the compiler, only after I manually delete the file and wait for 1-2 minutes for it to disappear.

What I have already tried:

  • Scanning the computer for malware/viruses and all kinds of threats.
  • Deactivating/uninstalling the antivirus protection.
  • Checking the hardware for any problems (mainly my hard disk drive).
  • Deleting from safe mode works (but I don't want to restart my computer every time I need to delete an exe file).
  • Have you tried external file Explorers apart from Explorer
    – techno
    Commented Jun 9, 2012 at 9:09
  • Tried another external file explorer, not working. Tried the solution offered by Guganeshan.T and it seems to work for the moment. Can you post that as an answer so I can accept it as a solution?
    – str82no1
    Commented Jun 9, 2012 at 9:22
  • If your problem is solved, you can answer your own problems and select it as the right answer.
    – SgtOJ
    Commented Jun 12, 2012 at 11:44

1 Answer 1


Just to save someone the time of traversing several links and then reading lots of irrelevant information, based on the link in the update I just did the following:

  1. launch services.msc
  2. Scroll down to Application Experience
  3. Double - click
  4. In resulting dialog set Startup type: popup to Automatic.
  5. Click OK

Note, I did NOT turn on Program Compatibility Assistant and so far it appears to have solved the problem.

Not the answer you're looking for? Browse other questions tagged .