4

On a Linux system it seems I can't kill my process I just started. ps -ax output:

6731 pts/1    DLl    0:06 ./main

I tried

kill -9 6731

but it just stays there. I don't have root access. What are my options?

  • You sure the process belongs to you and it is still running and not a zombie? – Bobby Jun 13 '12 at 11:13
  • Yes, belongs to me – ritter Jun 13 '12 at 11:13
2

It's blocked on disk IO (uninterruptible sleep). Is it on an NFS volume? It will be killed once it's unblocked.

If it is doing disk IO on an NFS volume and that volume is unreachable then you normally can't kill it. If you mount the NFS with "intr" option then you should be able to signal the process (kill it). If it is not mounted that way now then you probably will have to reboot to clear it. The best option is to just get the NFS server to come back and service the request.

  • It is on NFS volume. I didn't block it. Any options? – ritter Jun 13 '12 at 11:14
  • 2
    @Frank: Here "blocked" means "waiting for some function to finish", in this case it tried to read or write a file over NFS, but the NFS server might be down or something. If the filesystem has been mounted with nointr, there's nothing you can do. – grawity Jun 13 '12 at 11:24
  • Maybe bringing the network interface down and back up will unblock the NFS operation and let the process die. – Fran Jun 13 '12 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.