2

I'm new to Emacs in general, and even newer to org-mode. I'm trying to set up capturing, and running into a very basic problem: Symbol's function definition is void: org-capture. My impression from the manual http://orgmode.org/manual/Capture.html#Capture was that in the current version I no longer needed to, and shouldn't, load any extra packages like remember.el. But if it's not finding the function, I guess I might be misunderstanding something. Any guidance?

I'm running Emacs 23.3.1, Org-mode version 6.33x, on Ubuntu 12.04.

Edit: I hadn't realized I was running an old version of Emacs and org-mode, since this is a three-week old install. That explains things. But I don't actually know how to upgrade either one. Emacs 24.1 seems not to be in Ubuntu's repositories yet, and attempts to install it from the binaries (which I'm not even sure is a good idea, over top of an apt-get install of Emacs 23) keep running up against missing packages.

2
  • What does Emacs report if you run M-x org-version? Jun 13, 2012 at 13:18
  • Org-mode version 6.33x. Just added that the initial question. Definitely seeing the problem here; I had no idea everything was this outdated. I'm trying to install Emacs 24 now... Jun 13, 2012 at 14:19

1 Answer 1

2

There is no need to install Emacs 24 to use Org-mode's capture. Since you are running Ubuntu you can do

sudo apt-get install org-mode

to get a more recent version of Org-mode (currently you get 7.8 in Ubuntu 12.04). Then simply setup capture and you are done.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.