This is a tricky one. It is related to users with laptop from Sony or Toshiba with an ATI Radeon card (in my case mobility radeon HD 4650) with windows 7.

Sometimes you may want newer driver for your card (performance upgrades, sw compatibility such as hw acceleration in mozilla firefox .. or just having up-to-day sw :) ). For desktop cards this is not a problem - you simply download catalyst driver suite from AMD page and install it. However mobility cards on certain laptops cannot be updated this way - they need driver created by the laptop manufacturer, which is often outdated (the one for Sony laptops is from 2009).

I have tried the mobility modder utility on 10.6 and 12.2 catalyst versions, but to no success - the modder did not seem to actually modify the installation files (as seen from files timestamps). This problem seems to be experienced not only by me ( here ). I have also tried to update the driver manually via 'device manager'

Is there any other way to update the drivers (except for waiting for manufacturer to release the updated driver - I frankly don't believe they will)?

Also, is there any good reason why the hell are the laptop manufacturers forcing this policy when they are unable to release up-to-date drivers?


On 2 Sony VAIO different laptops (5 times installed) I was able to do the following:

  1. Download the full AMD driver package. not the ~1MB "detection"/verification tool. They are usually a bit hidden but can be found nonetheless. The file should be ~100MB (32-bit) or ~150MB (64-bit) Current 64-bit, 32-bit. (Windows Vista/7)

  2. Start the installation and install as normally. This finished it on 3 of my 5 installs (both laptops, seems to be hardware, windows version and catalyst version dependand)

  3. If that doesn't work, go to the device manager

  4. Select the Radeon display adapter device

  5. Select "Update driver"

  6. Select "Let me pick"

  7. Select "Have disk"

  8. Select the package extract directory, defaults to: "C:\AMD\Support\XX-X_vista_win7_64_dd_ccc_whql" and go to the "Packages\Drivers\Display\W76A_INF" subfolder

  9. Select the proper model (if different options are available). If none are shown you can uncheck "show compatible hardware" but then be very careful as your driver might not work or you have incompatible drivers.

  10. Continue installation

Note that this might make your laptop unusable, depending on how compatible the driver is. Best case you only disable some very minor vendor-specific features, worst case you'll need to reinstall the vendor driver (using safe mode) or even reinstall windows if you don't succeed with that. I'd recommend at least making a restore point.


There is already a guy with the same problems as the rest of us who found a solution.

Since a while he has been releasing the updated drivers, but they needed a program which messed up the certificate checks of windows, so i neither liked (and installed) it nor suggested it.

But since a little while he, thanks to the support from the community, managed to buy a certificate and now his drivers are signed: they can be installed like the original ones.

http://leshcatlabs.net/ is the site, you can find the most recent drivers (even the beta ones), and in the pack there are even a few utilities that can help solve some problems. Right now i have installed the 13.4 on my aspire 4820tg, while the most recent drivers Acer provide are from 2011.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.