26

At my job, I ssh into a development server everyday. I usually use exceed XStart to ssh in, but I downloaded PuTTY to see if I could do anything that I couldn't do with XStart.

I spend almost the entire day looking at the regular white background/black text terminal. The TERM variable in the server is set to vt100, and as far as I know, it's an eight-color display.

I was wondering if there was a way to have PuTTY emulate a 256 color terminal. I would really like some syntax highlighting in Vim, and the built-in ones are just awful. I've tried vim -T xterm-256color, and that only seems to let me use the default color schemes.

I also tried setting t_Co=256, but that doesn't work either.

If it helps, the dev server is a Red Hat 6 box.

52

1. Configure Putty

In Settings > Windows > Colours there is a check box for "Allow terminal to use xterm 256-colour mode".

2. Let the app know

You'll probably have to change Settings -> Connection > Data > Terminal-type string to:

xterm-256color


if your server has a terminfo entry for putty-256color, typically in /usr/share/terminfo/p/putty-256color, you can set Putty's Terminal-Type to putty-256color instead.

The main thing here is to make the server use an available Terminfo entry that most closely matches the way Putty is configured.


See also http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/terminfo.html

10
  • 2
    I have just verified that I can get 256 colors in Vim with PuTTY when that option is enabled. PuTTY seems to set the TERM to "xterm" automatically for me; you may still need to manually do ":set t_Co=256" within Vim.
    – Heptite
    Jun 14 '12 at 17:48
  • I tried the Allow xterm 256-color mode, and that hasn't done anything. I also changed the terminal string to xterm-color, that also did nothing.
    – Tom
    Jun 14 '12 at 19:54
  • 1
    @Tom the terminal should be xterm-256color
    – bahamat
    Jun 14 '12 at 21:46
  • 1
    @Tom: All other systems that I've used use xterm-256color. If putty doesn't do anything with that I'm not sure anything else can be done. Check this page: http://www.frexx.de/xterm-256-notes/ and try the 256colors2.pl script to determine for sure wether or not it's working.
    – bahamat
    Jun 15 '12 at 18:10
  • 1
    @RedGrittyBrick xterm-256color was the key in Putty that I have been missing all these years! So awesome. And thanks Heptite for that comment about t_Co=256 too. Jun 14 '16 at 10:34
10

I recommend the putty-256color terminal type instead of xterm-256color, if the system you're logging in to includes the appropriate terminfo file (or if you have permissions to install the terminfo file there). The putty/putty-256color TERM has better support for some keys (e.g. F1-F4).

4
  • Setting putty-256color without a ~/.terminfo file will result with the following when using certain programs, such as nano: Error opening terminal: putty-256color.
    – JW0914
    Feb 11 '18 at 14:52
  • 1
    That's why I mentioned that the terminfo file should be already present on the system, or installed locally. Feb 12 '18 at 15:24
  • 1
    This added the terminfo files I needed: apt-get install ncurses-term
    – roeland
    Jul 18 '19 at 16:27
  • I agree with using putty-256color. I tried using xterm-256color in the Terminal-type string. (Tested in KiTTY) It seemed ok at first but when I started KiTTY and got back into screen, it resized the window to 80 columns. putty-256color does not have this problem and the colors work. Feb 22 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.