4

I'm trying to get GIMP to display as a single window in XMonad. Currently, it's floating strangely in front of every other display and I can't use it.

I have tried reading this:

http://www.haskell.org/haskellwiki/Xmonad/General_xmonad.hs_config_tips#Gimp

But it seems this is for versions of GIMP before 2.8 when there wasn't the option to have GIMP use only 1 window. Because of this, it's an XMonad problem, not a GIMP one.

How can I do this?

  • Whats your Xmonad version? – Nima G Jun 21 '12 at 13:09
  • @Nima version 0.10-4 – Pubby Jun 21 '12 at 22:51
  • Ok can you provide your xmonad.hs? – Nima G Jun 22 '12 at 9:00
  • @Nima The only thing I have changed in it are different keybindings, otherwise it's the default. – Pubby Jun 24 '12 at 0:09
  • I wish GIMP/Steam/Evince would stop trying to badly manage windows and leave the window manager to do its job! – Mark K Cowan Jan 16 '17 at 23:59
10

Gimp 2.8 has an option under the "Windows" menu titled "Single Window Mode". Check that, and restart Gimp.

pic of option in gimp

  • Uh, maybe a whoops... Does this option not help with Xmonad? Go on people, flame me... {sigh} – lornix Jun 19 '12 at 3:42
  • I have that option checked but XMonad is treating it strangely and floating it in front of everything else. – Pubby Jun 19 '12 at 3:51
  • @Pubby: Try to dock the floating windows to the right and left sides of the central window. – harrymc Jun 19 '12 at 13:53
0

I'll try again.

How to unfloat Gimp

The link has quite a bit of information on using Xmonad. Several references to this page.

One more, specifically concerning Gimp:

look in the responses below the main part of the article

The relevant part:

But xmonad also floats all gimp windows by default. I use this to avoid floating the main two windows:

managehook = composeall [
    gimp "toolbox" --> (ask >>= doF . W.sink),
    gimp "image-window" --> (ask >>= doF . W.sink),
    manageHook defaultConfig
]
where gimp win = (className =? “Gimp” (fmap (win `isSuffixOf`) role))
role = stringProperty “WM_WINDOW_ROLE”
  • I think I'm just going to quit now while I'm ahead... I just posted the SAME link... {Sigh} I'm terribly sorry to have bothered you.. Any chance on some love for the SECOND link? – lornix Jun 19 '12 at 4:03
0

OK, I had the same problem and figured out the best solution (at least for me) while I was looking online for one: Simply go to window -> single-window mode. Then make the window go to fullscreen with mod + t (this is the default binding).

I know the first part was already answered, but that part alone only gets all gimp windows together in one, it still is a floating window, and I don't like that in my xmonad.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.