I have Macbook OS 10.7.2 and Galaxy Tab 7.7 I want to transfer files to and from these devices, but when I connect the tab to the laptop using the USB cable that came with it, my laptop doesn't recognize it.

On the tablet I get a small icon near the clock that says "USB Connected/MTP Connected" , but I get nothing on the laptop..

I read somewhere that I should download a program called "Android File Transfer" on my Mac.. I did that, and when I open it I get "No Android device connected"

I tried restarting my tab, and changed USB ports several times but I'm still getting the same thing..

What can I do?

(Update: I also tried "USB debugging" , but I still get the same result)

Please help, thanks!

migrated from stackoverflow.com Jun 14 '12 at 21:31

This question came from our site for professional and enthusiast programmers.

  • If the question is about data transfer it should have been migrated to android.stackexchange, not here. If it's about setting up ADB for development it should go back to stackoverflow (though the fix is simply to enable USB debugging in the tablet's settings menu) – Chris Stratton Jun 14 '12 at 21:32
  • 2
    This question seems to be about troubleshooting the connection of an Android device to a computer. It really could be here, or on android.SE. It will probably be better on Android though. – Austyn Mahoney Jun 14 '12 at 21:46
  • There are two separate aspects of that connection, one is a usage question and the other a dev tools question. – Chris Stratton Jun 14 '12 at 22:27

You might not have drivers for the device installed. Way 1 of doing this is downloading and installing Samsung Kies which installs the necessary drivers for the tablet and allows you to syng stuff with it. The second way is to just install the drivers. The second way is to look for help and drivers from this website: http://www.samsung.com/hk_en/support/model/GT-P6800LSATGY .


According to this thread, Airdroid is a good work-around. I'm not sure why Android File Transfer isn't working with your Galaxy Tab, it works fine with my Android device running ICS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy