0

I've managed to install Ruby and the gems install (rvm?) but now I'm stuck actually installing Ruby on Rails.

Every time I execute, gem install rails Terminal says that it's fetching each file and that it successfully installed it:

1 gem installed

However when I then run the rails command, I'm told that it's not installed and to run the gem install rails command again.

I've attempted to install with sudo but the same thing happens. I've restarted after an install and that's not worked.

Ideas?

  • To help troubleshoot your install, please run the following commands in your terminal ($ is the terminal prompt): $ which rvm $ which ruby $ ruby -v $ gem list – Jason Noble Jun 18 '12 at 14:01
  • check your $PATH environment variable. – iMom0 Jun 18 '12 at 15:03
  • Do you see it in the gem list? – Simon Perepelitsa Jun 18 '12 at 16:58
0

First select the "global" RVM gemset by

rvm gemset use global

then install rails and other gems.

gem install rails

Now it works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.