I have installed Win7 and Ubuntu both on this machine.

When I try to connect to my vncserver running on CentOS from my home computer behind a firewall, I get an error:

VNC conenction failed: vncserver too many security failures

... even when loging with right credentials (I reset passwd on CentOS).

Is this caused by attempting to log in as root? I think it is also important to note I have to login to remote Centos through port 6050 - no other port works for me.

Do I have to do something with other ports? I see that vncserver is listening on 5901, 5902 if another added - and I consider connection is established because from time to time (long time) the passwd prompt appears... right?

Even if prompt appeared and I put correct password I get an authentication failure.

How to disable this lockout for testing purposes?

4 Answers 4


I saw this error even though I only ever login from a single client machine with correct credentials. Looking in the logs, I saw that was being blacklisted rather than specific IPs. My understanding then is that a failure from any IP is counted as a strike against every IP thus leading to the "too many security failures" issue. It seems this bug report describes things similarly. Using the suggestion there to shut down black listing (which if you have setup you server securely is of limited value), I ran this command on an ssh session on the machine running my vnc server replacing 5 with the appropriate display number:

vncconfig -display :5 -set BlacklistTimeout=0 -set BlacklistThreshold=1000000

After running this I was able to successfully connect with my vnc client and login. For me this was great as I had a lot of running processes associated with my vnc server which makes restarting it a pain.

  • 1
    This did work. It is possible to use vncconfig command right away again, like vncconfig -display :5 -set BlackListTimeout=600 -set BlackListThresholds=10, to enable the protection again after resetting it.
    – Zrin
    Dec 3, 2015 at 21:30
  • Thanks, It works for me (ubuntu 1404), I do not need to kill and restart vncserver again and again.
    – bronze man
    Nov 9, 2019 at 1:46

"VNC conenction failed: vncserver too many security failures"

Means that someone tried to log in with incorrect credentials too frequently within a specified period of time. What that number and time is vary depending on what VNC Server you're using.

Someone's probably running a script trying to log into anything it can find listening on the standard VNC ports, and you'll need to find out what ip this is coming from and block it. Either way, this is really off-topic here - ask again over at SuperUser.

  • 1
    I know it already. this might be one of 100 causes. how to find it and how to block it? and wait a second, it cannot be "someone" but my ip, because it works for particular ip. how could be otherwise: than I could receive this error if anybody was trying to login, and I wolud have no way to login.
    – 4pie0
    Jun 15, 2012 at 17:17
  • another question: how to login as root? is it possible? when logging you are asked only about IP and password, so how to login as root to see root session?
    – 4pie0
    Jun 17, 2012 at 22:08

I have this problem too. If you use ThightVNC java client, you can connet only by changing the port of VNC client, try port 5002; 5003; etc


Have the same problem though I know for a fact it is my fault. I tried to guess my password (I forgot) so after that popped up I went here and then logged onto an SSH session, tried the command "vncconfig" and it said: pi@IZdesktop:~ $ vncconfig -display :5 -set BlacklistTimeout=0 -set BlacklistThreshold=1000000 -bash: vncconfig: command not found

Anyway, I would suggest trying this: logon in the computer with a monitor, and backup your files than reset.

P.S. I use a raspberry pi B+ Model 3

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .