I'm trying to set up file sharing access on a fresh Windows XP Pro machine, but the clients are getting access denied messages when I map drives or browse to them.

The accounts set up on the server are all set up to access the share (via the advanced sharing options, not the "simple" wizard), with full control - and have non-blank passwords.

I've tried quite a few things to get get them to work (mainly permissions) and have now run out of ideas...

What else can I try to get the remote machine(s) to "see" the share? Client machines have seen other shared resources before, and nothing has changed on them...

edit: Further info - the only way I have made the shares accessible is by setting full control for the specified users. I only wanted to allow read only access so this is sub optimal, though not a total showstopper.


Try again with all firewalls off.
Only if the problem still exists, here is some more:

Here's some useful documentation (although you probably know all this, it's always a good idea to go over the basics again while searching for a missing step). The first by Microsoft is pretty detailed, while the second is quite short and only intended for you as a flight-checklist:

How to configure file sharing in Windows XP
Share Files in Windows XP

If everything still fails, you might alternatively opt for sharing via the Shared Documents folder, which doesn't require too many permissions.

  • yep, firewalls off. already went to the first link, but i'll check the second. looks like i'll probably leave the full control setting for now. – geocoin Sep 19 '09 at 13:51

Have you made sure that as well as enabling sharing you've checked:

Properties > Sharing > Allow network users to change my files

on the shared folders?

alt text

I've just noticed the firewall information on the bottom of this dialog - which you get when you have simple sharing enabled. Have you allowed other machines on your local network full read and write access through any firewall you've got running? "simple sharing"

  • That doesn't appear to be an option. is that simple sharing only? this is advanced sharing mode – geocoin Sep 19 '09 at 12:11
  • It's on the folder being shared - and my machines are in a Workgroup rather than a Domain, so that probably has some bearing on it too. – ChrisF Sep 19 '09 at 12:17
  • Hmmm this is on a workgroup, not domain, so I'm not sure why I cant see that option. – geocoin Sep 19 '09 at 13:08
  • Thanks for the added pic. I had that property sheet before I changed to advanced sharing from simple sharing. Now it's different, it looks like this: practicallynetworked.com/sharing/xp_filesharing/image9.gif anyway, I enabled full control, in the permissions which is probably equivalent and now it works, with the caveat that I only wanted to allow read access. Also all firewalls were off while troubleshooting this. – geocoin Sep 19 '09 at 22:20

Are both the machines in the same workgroup? Try going to a command prompt and typing

net use <driveletter>: \\<remotemachine>\<sharename> /user:<remotemachine>\<username> <password>

using any available drive letter and see if that works, if not it should give you an error message with a number which will give us some clues as to why not

  • yes both machines are in the same workgroup. – geocoin Sep 19 '09 at 13:03
  • have you tried the command, the password should be the users password on the remote machine – Col Sep 19 '09 at 15:37

You must also make sure that the NTFS permissions allow the same access to the files that the share permissions give.

  • I think this may be the root of the problem. When I get back to it, I'll check it out – geocoin Sep 19 '09 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.