2

While connected to a VPN (SwissVPN service), a content filter at a site I'm working at blocked a web page. This was perplexing, since the local site's filter should not be able to see my traffic, right?

So I assume my web browsing activity was not going through the VPN tunnel. How can I configure the OS to send ALL traffic though the currently connected VPN tunnel? I'm using OS X Lion and Windows 7.

  • Ensure that you only have one gateway set, and make sure it's the VPN. If you were filtered due to location, then it may have be gathered through means other than where your VPN's address is located. What's the actual problem you're facing (filter type? why are you filtered?), and what have you tried already? There's MANY questions related to this on here with lots of relevant information. – Ƭᴇcʜιᴇ007 Jun 15 '12 at 23:39
4

You can enable that feature on OS X by going to:

System Preferences → Network → Your VPN Connection → Advanced → Send all traffic over VPN

On your Windows 7 box you can go to:

  • Open Network Connections
  • Get Properties on the VPN connection you set up
  • Under the Networking tab, get Properties on IPv4
  • Click Advanced
  • Turn on Use default gateway on remote network

That should make it so all traffic is sent over the VPN on both systems.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy