Possible Duplicate:
Why is all my extra RAM marked as “hardware reserved” in Windows 7?

I recently got rid of my 2 × 2 GB sticks of RAM to get myself some new 2 × 4 GB and much better sticks. I'm running Windows 7 64-bit.

The problem is, I installed these sticks and Windows only seems to want to use 3.18 GB, out of 8 GB available... It marks the remaining RAM as "Hardware reserved", and there is no way for me to use it.


1 Answer 1


First, adding more RAM will not likely help increase your WEI (Windows Experience Index) score or not increase it very much unless the RAM itself is faster. So I hope that's not why you upgraded. However, adding more RAM will probably help if you're the type of user who never closes windows or runs complicated/intense programs.

Anyway, you will almost certainly have to get into your BIOS settings and find the area where RAM is dealt with. Usually, pressing the DEL key or F2 or something will get you into the BIOS settings. Once in, there should be something that lets you adjust a "memory hole." It's usually enabled when it should be disabled or vice-verse (it depends on the BIOS and manufacturer). Toggle that setting and try to get your system to count all the RAM during the next power on. If your BIOS can't count all the RAM then Windows isn't likely going to be able to use it either. In fact, you may need to flash update your BIOS to gain the ability to use more RAM. But before you do, I'd suggest checking with your motherboard manufacturer to see if your motherboard can even use 8GB of RAM since you may have just wasted your money! (I hope not.) And if this is a laptop/netbook then you'll need to check with whoever that is instead.

Hope it helps...

Not the answer you're looking for? Browse other questions tagged .