So long story short:

I dropped the wrong app into 'clean my mac' and I hit 'cancel' but it was too late by that point.

I rebooted and appstore said it had an update, when I opened appstore it was showing an update for the app I just uninstalled.

I tried clicking 'update' but it gives me an error saying it's unable to install after 'downloading'.

When I try to go into 'purchased apps' it shows the app as uninstalled so I click 'install' and I get an error saying it's already installed.

I'm running Lion OS X, latest version, updated, mac book pro is only a few months old.

I tried searching through the entire system to remove all traces of the app, after rebooting appstore no longer shows the app and no longer shows the update but on the apps page it still says 'Update'.

I tried reinstalling the app from desktop OUT of the appstore and again says the app is 'already installed'.

So after reading more about lion I found an article that spoke about 'BundleID' being the thing that tells appstore what's installed and needing updating however I can't find the location of where the BundleID would be.

Any thoughts?

I've tried CCleaner, AppCleaner etc and none of them show the app, mainly because it is uninstalled.


I've spoken to Apple Support who confirmed that there is a file in the system that connects separately to tell the system if there are updates available however they declined to inform me of any further details.

Apple also referred me from technical support to iTunes App Store opposed to Mac App Store support and from there I have been referred to AppleCare who are currently 'investigating' this issue.

Hopefully there will be a fix that's simple to implement for people having similar issues, this appears to be a more common issue than I previously thought.

| improve this question | | | | |

This fix is NOT supported by Apple's Official Support Policies

  1. Open Terminal
  2. Paste these codes in one line at a time:

    rm -r ~/Library/Caches/com.apple.appstore
    rm -r ~/Library/Caches/com.apple.storeagent
    rm ~/Library/Preferences/com.apple.appstore.plist
    rm ~/Library/Preferences/com.apple.storeagent.plist
    rm ~/Library/Cookies/com.apple.appstore.plist
  3. Navigate to: Launchpad > System Preferences > Spotlight > Privacy (tab)

  4. Click '+' in the bottom left
  5. Select 'Macintosh HD' (click ok when prompted)
  6. Leave it a few minutes and then click '-' to remove it
  7. Type something in Spotlight and wait for it to begin 'Re-Indexing'
  8. Once Spotlight has finished reboot
  9. Install the App out of App Store (this should work now)
  10. Once installed open 'Applications' locate app
  11. Right click and select 'Show Package Contents'
  12. Remove the file named 'embedded.mobileprovision'
  13. Remove the folder called '_MASReceipt'
  14. Reboot

When the Mac App Store launches it scans ALL apps regardless of if it was installed via MAS, it picks up the apps that were installed via MAS and then provides any updates, once the update has been triggered it gets embedded into those files (via an encrypted string) and remains there until cleared or updated.

This method removes the files that contain parts of the update string, when the app store cannot find the string it clears the update status and you should be good to uninstall and re-install via app store (I've just done this successfully) and/or update to a newer version.

This method was advised to me by an Apple staff member off duty and therefore does not actually represent Apple's Official Support Policies.

| improve this answer | | | | |
  • 1
    Worked for me. Had terrible trouble with updating Growl from 2.0 to 2.0.1. I tried everything I could think of, which included several of the steps you mentioned. Then when I came to this article, I followed everything in sequence up until deleting stuff out of the app. It seems to work. Had to keep clicking install in the App Store even after the fix and it kernel panicked on me! I reboot the machine, reset ACLs, tried once more, and it finally is updated. Hell of an update! – user179931 Dec 13 '12 at 4:42

Go to updates in App Store. Click store in menu bar. Click reload page.

This worked for me.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.