For some reason Google Chrome is slow when I'm working against localhost. I had the same problem in Firefox 3.5 but I changed some IPv6 setting in about:config which fixed the issue. I think the same problem occurs in Google Chrome, but I can't find out how to fix it.

Any ideas?


2 Answers 2


Just an idea : do you have a line that looks like this :

::1 localhost

in your hosts (it should be somewhere like C:\WINDOWS\system32\drivers\etc\hosts, if I remember correctly) file ?

If yes, comment that line by adding a # at the beginning.

This way, the only line that's about localhost should be    localhost

which is IPv4.

It might help, if your problem is really caused by IPv6.

  • You're welcome :-) Was just a wild guess, but nice to seen it worked ! (might be useful one day on another, actually ! ) Sep 19, 2009 at 15:56
  • @blahblah - You should mark Pascal's answer as "accepted". @Pascal - thanks so much for this fix, this was really slowing me down as I was testing sites locally in Chrome. Sep 28, 2009 at 12:49
  • 6
    This makes a huge difference. Both lines were commented out for me in Windows 7, so I uncommented the IPv4 line and everything works great now.
    – Ben Mills
    Feb 1, 2010 at 16:27
  • 2
    I've been using this fix up until Chrome 8, but now that Chrome 9 has been released, it seems to be slow again. Has anyone found a fix for the current version?
    – Douglas
    Feb 21, 2011 at 10:45
  • 3
    Can someone explain why does this work?
    – Pacerier
    Jul 16, 2012 at 17:01

Deleting cookies and site data of localhost from chrome settings worked for me.

  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Nov 18, 2021 at 13:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .