I have an ASUS M4A78LT-M-LE motherboard, and I bought a new stick of RAM for it (Kingston KVR1333D3N9 - 4GB, 10600 CL9), however when I put this new stick in, the computer does not boot. It powers on, but the screen stays black, hard drives do not spin up, etc. This occurs when I put the new RAM stick in alongside the old one or by itself in either of the two DIMMs.

Thinking that the RAM stick was faulty, I took it back for a replacement, but the replacement suffers from exactly the same problem./

What could be causing this? Is the RAM not compatible? Should I be buying a different brand or is my motherboard faulty?

The RAM timings in the BIOS are all AUTO.

The old RAM stick is 2GB G-Skill DDR3 CL9. I am 100% certain that the motherboard is ASUS M4A78LT-M-LE (sudo lshw), and both RAM sticks are DDR3.

  • What brand are the old RAM sticks and what size(s)? Jun 19 '12 at 3:26
  • @tumchaaditya If you read all previous comments, the OP stated his board supported both. Which is not impossible as I have seen boards that can do this. Jun 19 '12 at 4:26
  • This bios flashing worked! Thanks so much everyone!
    – Mike B
    Jun 19 '12 at 5:56

Please make sure you reseat the RAM sticks firmly (Until you hear two clicks, then push a little more.), and also try them in different DIMM slots. Make sure there is no dust in the way inside the DIMM or on the RAM itself.

If this does not work I would try them in another computer to attempt to find the real issue - the replacement sticks (unlikely, just like what psusi said), or the Motherboard. I did a little Googling, and it appears that psusi is right about BIOS updates. There are some and you can get them from the ASUS website for your laptop here. If you need instructions on installing the new BIOS update, don't hesitate to comment on my answer.

EDIT> I did not even notice that you changed from DDR2 to DDR3. Robotnik is right. Although, I am unsure how it's possible for you to mistakenly insert DDR3 into a DDR2 slot, as the RAM sticks have notches at different levels along the stick to prevent just that.

EDIT2> Nevermind, I have before seen computers that have the ability to support both DDR2 and DDR3. Awesome dude.

  • I'll try putting the stick in both DIMMs again (although I've already tried all combinations), and if it doesn't work I'll update the BIOS and report back.
    – Mike B
    Jun 19 '12 at 3:59
  • Updated my answer with information from your edit. Nothing important, just a fix to remove something that isn't needed any longer. Jun 19 '12 at 4:02

According to the product information page (which isn't always 100%) and the downloadable qualified compatible memory vendors and products... there is no compatible 1333 Kingston with that board. That doesn't mean it definitely wouldn't work, just lowers the probability.

According to the downloadable manual, there are two Kingston 1333 sticks listed, but one is 1gb and the other is 2gb... as far as compatible memory is concerned.

However, the manual says nothing at all about the board being able to use both DDR2 and DDR3 Ram. More importantly...

Difference between the two

(image from Makeuseof.com)

... there is a physical difference between the two sticks, in the placement of the notch in the stick, and thus the placement of the pins that touch the contacts. Examining the top-down image of the board, you can clearly see where the notch would go in the Ram slots, so it isn't like there isn't a notch there. You can't physically put a DDR2 stick in either of those slots for the board you mention.

The Asus M4A78LT-M LE

There are motherboards that will come with slots for both types of Ram... this is just not one of them.

If you are POSITIVE that the old Ram is DDR2, and you are POSITIVE that your system worked fine with it, then you must be mistaken about the motherboard model number.

But at the very least, there is no way that with the information you supplied that you were able to put DDR2 and DDR3 interchangeably in the same slots.

  • Sorry you're absolutely right, the old RAM stick is DDR3 ! I'm completely certain of the motherboard number.
    – Mike B
    Jun 19 '12 at 5:12

Either both the original and replacement sticks are faulty ( seems unlikely ), or your motherboard/bios is. You might see if there is an updated bios for the board.


If your motherboard supports DDR2 and not DDR3, Then the new stick is not compatible. You'll either need to stick with DDR2 (pardon the pun) or buy an new motherboard


  • I've looked it up and the motherboard is supposed to support DDR3, I'll add this to the question.
    – Mike B
    Jun 19 '12 at 3:56

Wait a moment....
you cannot replace DDR2 RAM with DDR3 unless you change the Motherboard(or your MoBo has both DDR3 and DDR2 slots which ain't the case with M4A78LT-M-LE)...
And DDR3 sticks wont physically fit into DDR2 slots.
Look this image and you will realize why: http://site.bixnet.com/images/products/ddr-compare.jpg

What exactly are you trying to do here?
Have you recently changed your Motherboard as well?

Actually, M4A78LT-M-LE does support DDR3..
So if you indeed are having this motherboard, then press RAM sticks until the locking clips are in place.
Just make sure you are correctly matching the notch on the RAM stick with the slot.

  • Again, there are boards that support BOTH DDR2 and DDR3 sticks. Jun 19 '12 at 4:37
  • and M4A78LT-M-LE is not one of them. it has 2 slots and both are DDR3. I have used the board myself. Jun 19 '12 at 4:41
  • I was just saying you make it sound like you don't think that any board can do it. Not just this one. Jun 19 '12 at 4:42
  • yeah....my bad..... i should mentions slots....not board.. and i have edited the answer to correct it. Jun 19 '12 at 4:44
  • Sorry this is all my fault, the old stick is DDR 3!
    – Mike B
    Jun 19 '12 at 5:12

I have experienced a similar problem with an MSI 760GM-p-23 (FX) motherboard with an AMD FX-4100 CPU. I have got various DDR3 PC3-10600 (1333MHz) SDRAMs, and the computer does not always boot, or does boot but gets memory errors (membist86+ errors).
I run the "memtest86+" memory test program, some memories have enough errors that I
cannot reliably use them. These are not (all) used memories from ebay, these were new Patriot and Crucial memories from Fry's. In fact the best results came from a used Micron/HP memory from Ebay.

I may try flashing the BIOS, but it may be a signal integrity problem. A friend who used to build motherboards, says he does not do it any more, but just buys HP computers, and uses the memories on their recommended list.

Not the answer you're looking for? Browse other questions tagged or ask your own question.