I'm having quite a weird problem when trying to install Windows 7 SP1 on a new Corsair Force Series 3 SSD to replace a failing HDD in my wife's laptop.

When I boot to Windows install, it shows that I have no disks to install to, and tells me to find it a driver to any custom disks I may have.

When I go to repair option on the first install window, and then open command prompt Window, I can see the disk using diskpart, and can partition it and format partitions, and then later access them from command prompt and copy files to them.

After creating partitions, clicking the "browse" button in Windows install screen that shows no disks available to install Windows to, does show the partitions created by diskpart!

So, it does detect the disk and partitions, but refuses to list them as options to install to.

People on the Interwebs seem to suggest that just running diskpart "clean" solved the issue for most people, just creating an "active" "primary" partition is al most tutorials suggest. Both got me only as far as described above.

The BIOS doesn't have RAID option, changing between "ATA" and "AHCI" (the only available options) didn't make any difference.

Might be worth mentioning that this is on a laptop that has Sata III controller for main drive (which I connected the Sata3 SSD to), and Sata II for DVD (which I used for Windows install media). That's what googling brings at least (DELL XPS 15 L502).

Any ideas?



The SSD is 460 GB. I tried setting it all as one partition and creating 70-90 GB partition as well (NTFS).

More importantly, Windows doesn't list the partition as one it cannot install to (which it does with disks in general when they are small for example). What happens here is different. It doesn't list anything at all. It shows empty list of drives.

  • 1
    How large of an SSD? – Canadian Luke Jun 20 '12 at 0:02
  • Windows 7 will install to volumes that are both NTFS and large enough (I'm not certain about the exact number, but I recall it demands 7-10GB). Is the partition you created and formatted large enough and NTFS? – Synetech Jun 20 '12 at 0:06
  • It's the 240 GB one. – Meligy Jun 20 '12 at 0:07
  • The drive may be, but how big is the partition? Are you sure you formatted it to NTFS? – Synetech Jun 20 '12 at 0:07
  • 1
    Is the original, failing drive installed/listed? – Synetech Jun 20 '12 at 0:32

When you get to the screen where it is supposed to show a drive to install to look for a link that says drivers, you might have to click advanced. On another computer download these drivers from dell. Unpack and cancel the install, make note of where it was unpacked to and go to this folder. There are 2 folders one says f6flpy-x86 and f6flpy-x64 copy the folder that resembles the OS you are trying to install to a pen/flash/thumb drive. Go to the laptop and plug the drive in and click drivers or install drivers tell it to search the pen drive and detect drivers that will work for your system. After it installs the drivers it should find your drive.

  • Sounded like a very good candidate. This is obviously the driver it needs. However, to my very surprise, this didn't work. It detected the driver but didn't list any drives after loading it. – Meligy Jun 20 '12 at 12:12
  • Just curious if you can try it on another system. Might be a bad ssd. – Phillip R. Jun 20 '12 at 20:30

Although this is not THE answer, but here is what worked, sort of...

  • I tried GParted to clear the SSD, it didn't change anything
  • During this, the Windows 8 Release Peview DVD was hanging and sometimes moving super slow. I wasn't ery keen on whether to choose Win7 or Win8RP
  • I formatted the drive into partitions again using GParted
  • It didn't change anything for Windows 7.
  • I tried Windows 8 RP again, and worked just normally!

So, it's not Windows 7, but we got a working machine anyway, espeically that we plan to get RTM Windows 8 on it when it comes anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.