I'm trying to install a 32bit Oracle instant client onto several Windows 7 PCs. This version is the one required by the customer's software. I have successfully installed it on about a dozen PCs using the same installer, but two machines refuse to register a DLL. The two PCs are of different make and model. I have been able to install this software in the past on these models. This is the error that the installer throws up:

Error during install

The file copies to the location referenced above. If I choose to ignore the error and manually register it later, I get the following error:

Error during regsvr32

This error is returned whether I use the 32bit (syswow64) or 64bit version of regsvr32. Command Prompt is run as admin, and the ID with which I'm logged into the PC is an admin. I've tried copying the file into the syswow64 folder, but I get the same error. This same installer works on other PCs.

To further complicate the issue, one of the two PCs also will not register an OCX file from a different 32bit installer:

Second installer error

Both PCs are relatively new and have standard software installed. We use MS Forefront for security, but disabling that didn't change the behavior. What am I missing?

  • You need to use the 64-bit installer if you are running Windows 7 x64. It makes no sense to install a 32-bit Oracle client when the 64-bit client is exactly the same. Downgrade the operating system to 32-bit and you won't have this problem – Ramhound Jun 21 '12 at 15:46
  • I should add that this is a corporate environment, so downgrading is not an option. The 32bit Oracle client is only a symptom. The problem is that the PCs cannot register 32bit DLLs. – Bad Neighbor Jun 21 '12 at 17:21
  • If you suspect that Windows is at fault, spend this time reinstalling it. Your opportunity cost is getting higher by trying to fix it. – user3463 Jun 21 '12 at 21:50

The error code you got stands for ERROR_MOD_NOT_FOUND, some dependent dll is missing on your system that both of those two programs rely on.

One tool I have used a lot for finding problems like these is Dependency Walker, it analyze the dll or the ocx and tell you what other dll's it depends on.

If it can't find it by static analysis you will need to do it by dynamic analsys and "profiling" the program. I have only worked with exe's so I am not sure how you would run the dll for profiling, perhaps you need to load regsvr32 in dependency walker and launch it with the arguments to load your dll and it may pick it up that way.

Once you figure out the missing dll and you add it back in to the system everything should work.


You could just download the 64 bit Client

  • As I commented to Ramhound, the inability to install the client is only a symptom. The problem is that the PCs cannot register 32bit DLLs. – Bad Neighbor Jun 21 '12 at 19:26
  • 1
    @BadNeighbor - The Windows installation is clearly corrupt so reinstall it. – Ramhound Jun 21 '12 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.