39

I'm wondering if it's possible to connect to a computer through TeamViewer without having the screen show what you're doing.

For example if it's a computer at home or at work which is standing where other people might be, I'd prefer to be able to use it without them seeing what I'm doing :)

3
  • 1
    I simply want to use my own computers remotely without the monitor suddenly flashing on. I rarely physically turn my monitors off when I leave. I just let them go into power-save mode. I'd pretty much just like it to not break that mode :) No dubious intentions!
    – Svish
    Jun 22 '12 at 16:31
  • 2
    I don't know about TeamViewer, but if you're willing to consider a different software package, LogMeIn has a special driver that blanks the screen when you connect, if you so desire.
    – nhinkle
    Mar 7 '13 at 4:13
  • With TeamViewer, for 2015, it's trivial. Note that it works perfectly whether your "client" computer is a Mac or PC (previously there was problems if you were using a Mac as the "cilent".) Simply go to the Actions menu -- MogsDad explains it.
    – Fattie
    Jul 9 '15 at 12:02
27

Look at the "Actions" menu. You need to "Disable Remote Input" first, then "Show black screen" will be enabled and you can select it.

The first time you use this feature, TeamViewer will want to install a display driver.

In the Windows App:

screenshot

If you're using Web Access (not the app):

screenshot

5
  • 7
    Long shot here....But is there a way to force it to do this EVERYTIME? It seems like a fairly big security issue to have to click that everytime. Who knows who is standing there at the other end...
    – canadmos
    Mar 14 '14 at 23:02
  • This is the correct answer for all modern (2015+) installations of TeamViewer. Thanks MogsDad!
    – Fattie
    Jul 9 '15 at 12:02
  • 4
    Although present, this feature is bugged and doesn't work in current version of TeamViewer (Sept 2017) Sep 20 '17 at 11:34
  • I don't see any actions tab in my teamviewer Mar 19 '18 at 20:38
  • don't understand why this feature is allowed as unscrupulous indian scammers black out the screen so the victim can't see what html they're editing on the user's bank account web page
    – Mikey
    Jun 19 '19 at 8:41
27
  1. Right Click the computer you want to edit

  2. Click Properties

  3. Click Advanced (lower left)

  4. Click Drop Down under Remote Input (bottom right)

  5. Select "Disable Remote Input and Show Black Screen"

  6. Log into remote computer from another Desktop edition of TeamViewer and accept the video driver TeamViewer offers

Note that you will need to do this for each device you have TeamViewer installed on.

1
  • If my home PC is locked and black screen because I forgot to disconnect from work, is there any way of logging back on from home? If local input is available at all, it seems odd black screen + enable input (require windows login) isn't an option.
    – tbone
    Apr 12 '18 at 17:17
3

Using RDP (remote desktop protocol) the built in remote access software in all versions of windows since XP will accomplish this to some extent- as soon as you start your remote session the remote PC will show the windows LOCK screen, requiring a person physically at the PC to enter their password to regain control (at which point you will be knocked off your remote control session).

To enable on the remote pc:

Control panel -> search "remote"  -> select "allow remote access to your computer"

OR

Control panels -> System -> select "remote settings" -> enable (and select
win accounts if you are not using the remote's administrator account and pass.)

On your local pc to connect to remote PC: run the built in (to windows) client app: "remote Desktop Connection"

1
  • 2
    The question is specifically about TeamViewer connection, not RDP Sep 20 '17 at 7:54
2
  1. Prior to connecting, in the Computer and Contacts window, right-click the remote computer you wish to connect to and select Properties.
  2. Under Action Settings, select Disable remote input and show black screen in the Remote input dropdown.

Alternatively, if you wish to manually blank the screen after connecting to the remote machine, in the Actions menu you can select Show black screen to force a blank, black screen to be shown on the remote monitor.

Source: http://codeyarns.com/2012/02/16/how-to-show-black-screen-on-remote-computer-using-teamviewer/

5
  • Please include a summary of the steps needed to accomplish the action needed. Just a link by itself is not considered a complete answer here. Please read How to Answer.
    – depquid
    Apr 1 '13 at 16:41
  • Not an answer, include the source for better answer but summarize it here as well please.
    – TomEus
    Apr 1 '13 at 16:53
  • 4
    Doesn't work in OSX. There isn't any Action Settings option when you right-click Properties. Also doesn't work from Android. Jun 24 '13 at 6:45
  • It now works fine if your Mac (remote client) is connecting to a Windows "host".
    – Fattie
    Jul 9 '15 at 12:04
  • @PaulHargreaves for OSX, connect to remote computer normally, then you need to click disable remote input first then show black screen
    – Korayem
    Dec 11 '15 at 12:27
0

According to this TeamViewer documentation article, there are several ways to do this. The easiest permanent option is probably via the Properties option of a computer found in Computers & Contacts.

For other means to do this, also permanently, see the article above.

Be aware though that the Black Screen feature is available only to customers with paid licenses now.

black-screen-option-contact-properties

-1

No, but you can try looking for other remote administration software. those which allow you to access the remote system in "stealth" are usually trojans or backdoors which are not appropriate to discuss here.

3
  • Yeah, my goal wasn't going stealth per se, just not trigger the monitors to "wake up".
    – Svish
    Jun 22 '12 at 16:32
  • 4
    So using the RDP built in to windows is mainly there for trojans and backdoors? ;) Jul 5 '13 at 7:26
  • It's now absolutely trivial with TeamViewer .. just click the menu items that says "show black screen" :)
    – Fattie
    Jul 9 '15 at 12:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.