15

I'm on Kubuntu, Firefox 3.5.

18

You're on Firefox 3.5, right? Then Sathya's solution is wrong.

According to the site he linked, the flag you must create shall be called

network.protocol-handler.expose.magnet

not network.protocol-handler.*external.*magnet, as he suggested.

Besides, you can initialize it to false and thus Firefox will ask you the program which you want to use. I just did it and it worked - no need to restart Firefox.

If KTorrent won't support Magnet Links, you might try qBittorrent, which I'm using succesfully.

  • Setting it to false really did bring up the dialog box for me to choose it. Thanks! – Helder S Ribeiro Dec 18 '09 at 19:25
5

Type about:config into the address bar and press Enter. Next, Add a key by Right-click -> New -> Boolean -> Name: network.protocol-handler.external.magnet with value -> true

Add another key, by Right-click -> New -> String -> Name: network.protocol-handler.app.magnet with Value -> ktorrent

Also, do ensure that the key network.protocol-handler.expose-all is set to true.

From Mozilla KB

  • Thanks! It's weird, but I did what you said and I'm still getting "Firefox doesn't know how to open this address, because the protocol (magnet) isn't associated with any program", even after restarting Firefox. Do you know why that could be? – Helder S Ribeiro Sep 21 '09 at 15:29
  • That's weird, will check it. – Sathyajith Bhat Sep 21 '09 at 16:09
3

This worked for me, FF 47, Debian 9, KDE 5:

1. In about:config find "network.protocol-handler.expose-all", change to "false";
2. Click on some magnet link - a file browser pop-up should appear, show it full path to the executable (/usr/bin/qbittorrent for ex.);
3. Change "network.protocol-handler.expose-all" back to "true";
4. Download the world.
2

ktorrent does not support uri links, by the way. http://ktorrent.org/wiki/index.php/FAQ#Does_KTorrent_support_magnet_links.3F i myself followed the sathya suggestion and i've had the same issue as you, obvio171. i'm running archlinux firefox 3.5.5-1 should we file a bug?

2

Go to:

  1. Tools
  2. Options
  3. Applications
  4. Find Magnet
  5. Under Action, select "use other"
  6. Find µTorrent or whatever is installed on your computer
  7. Done
2

I was using gentoo + Firefox 19. When I had the problem, adding stuff to 'about:config' won't help and I don't see "Magnet" under Preference -> Applications. Eventually I found the problem and it may have something to do with the KDE mime type configurations.

I changed /usr/share/applications/kde4/ktorrent.desktop by appending: x-scheme-handler/magnet; to 'MimeType=xxx'

Then I edited ~/.local/share/applications/mimeapps.list by inserting the line: x-scheme-handler/magnet=kde4-ktorrent.desktop

Then, if I click on an magnet link, firefox will pop up a dialog asking what application to use instead of saying not understanding protocol. After the pop up, you need to select ktorrent's binary (/usr/bin/ktorrent on my computer).

  • what happens after firefox pops up? Do you do something else? If not, then this isn't an answer. – Lizz Mar 25 '13 at 6:07
  • Oops. Sorry for missing out that part. Just edited. Thanks for the remind. – Steven Lai Mar 25 '13 at 7:00
  • nice and most correct answer, but will be erased on update, need to pull request ktorrent or open bug... so answer from @bruhal is quicker and will last – intika Apr 23 '18 at 9:23
1

Right click on the link then choose "save link as." When Firefox asks for which program you wish to open the link with and then select Ktorrent.

0

Because you should include the path of the Application on the network.protocol-handler.app.magnet "/Applications/kTorrent" instead of the app name

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.