This problem has been going for a while (ever since I installed Windows 7 on this PC): Every once in a while (randomly, with any application), when I use the mouse to left-click & drag (move window, scroll down, etc.), my PC crashes with the following problem signature:

Problem signature:
  Problem Event Name:   BlueScreen
  OS Version:   6.1.7601.
  Locale ID:    1033

Additional information about the problem:
  BCCode:   124
  BCP1: 0000000000000000
  BCP2: FFFFFA8007D3D028
  BCP3: 00000000B2000040
  BCP4: 0000000000000800
  OS Version:   6_1_7601
  Service Pack: 1_0
  Product:  256_1

Files that help describe the problem:

I consulted this Generic "Stop 0x124" Troubleshooting Strategy but nothing helped.

Using BlueScreenView, this was the only information that's available about this BSOD:

Dump File           Crash Time             Bug Check String  Bug Check Code  Parameter 1       Parameter 2       Parameter 3       Parameter 4
062412-16187-01.dmp 6/24/2012 6:28:29 PM                     0x00000124      00000000`00000000 fffffa80`07d3d028 00000000`b2000040 00000000`00000800 


Caused By Driver  Caused By Address  File Description  Processor  Crash Address      Processors Count  Major Version  Minor Version  Dump File Size  
hal.dll           hal.dll+12a3b                        x64        ntoskrnl.exe+7f1c0  4                15             7601           284,136


Filename     Address In Stack    From Address      To Address        Size       Time Stamp  Time String  
hal.dll      hal.dll+12a3b       fffff800`02c0d000 fffff800`02c56000 0x00049000 0x4ce7c669  11/20/2010 9:00:25 AM  
ntoskrnl.exe ntoskrnl.exe+18cb03 fffff800`02c56000 fffff800`0323e000 0x005e8000 0x4fa390f3  5/4/2012 4:18:59 AM  

As you can see, having the problem reported in the core system (hal + ntoskrnl) is not helpful at all because it doesn't point to a specific driver (mouse? display?) that I can update (if there is one) but rather to the system which is 100% up-to-date.

So it seems that my only hope is to find someone who actually recognizes this problem as having a very specific solution.

Any idea how to fix this problem once and for all?

UPDATE, MONTHS LATER: The problem still persists and it starts to annoy me. So far, it looks like only @Chiyou is in the right direction, so I am posting snapshots from the hardware monitoring driver that I installed specifically for troubleshooting this problem (I don't overclock, nor do I normally need the information provided extra CPU cycles it eats). My system is built around ABIT IP35-PRO:

enter image description here

Which results in what seems to be safe temperatures:

enter image description here

And voltages as well:

enter image description here

Any idea what to tweak?

  • 2
    Can you upload the minidump for advanced analysis? Also, disable non-MS shell extensions you don't need... Jun 25, 2012 at 1:28
  • @TomWijsman Unfortunately my CCleaner got rid of it. Maybe next crash... As for shell extensions you made me realize that I mistakenly wrote "right-click" when I actually mean "left-click". Thanks for that +1. Jun 25, 2012 at 14:44
  • 1
    have you tried logging into safemode and running "sfc /scannow" to replace all damaged system files?
    – Arturski
    Jun 28, 2012 at 13:00
  • @Arturski Yes, I logged into safemode and ran sfc /scannow and got "Verification 100% complete. Windows Resource Protection did not find any integrity violations.' Sep 28, 2012 at 20:30
  • "The problem still persists and it starts to annoy me." but still no dump? Anyhow, just wanted to mention that WHEA errors are recorded in the event log too. One of these will contain the answer to your problem... Nov 29, 2015 at 17:50

1 Answer 1


Bsod 124 is a generic hardware failure and most likely it's from overclocking or a bad vcore or bad psu. Things you can do: revert to stock, up the voltage of cpu, ram or northbridge. Maybe post your psu and box spec so that we can see if it's the psu?

"x124 WHEA_UNCORRECTABLE_ERROR is a GENERAL hardware problem, but in most cases as you said, it's related to an unstable overclock, usually not enough vCore, etc. However, it is not just an overclock problem, or just related to overclocking. x124 can be triggered from failing memory, overheating, etc. Windows passes on the hardware error report in the form of a "stop 0x124" because it can't do anything else once the hardware has signaled an uncorrectable fault condition."

  • I finally got to install uGuru for my motherboard, in order to post the information you were referring to. Any suggestions where to go from here? Thanks +1 for now. Sep 28, 2012 at 19:46
  • 1
    Why is your extclk so high? Isn't that the fsb and should be 200? If you don't overclock I would try to replace ram, videocard and psu.
    – Micromega
    Sep 28, 2012 at 20:06
  • Are you familiar with this mobo? Should it really be 200MHz instead of 272MHz? If so, why does system works PERFECTLY with Ubuntu but not with Windows 7 64-bit? Sep 28, 2012 at 20:27
  • 1
    I didn't know you use Intel. Maybe reinstall Windows? My problem is also overclocking and I have revert almost to stock.
    – Micromega
    Sep 28, 2012 at 20:32
  • "Maybe reinstall Windows"??? Sorry, this is not an option. I think you were onto something (tweaking some voltage due to Windows 7 being pickier than Linux for some strange reason). But which voltage? VCore? DDR2? MCH 1.25V? ICHIO 1.5V? CPU VTT? DDR2 REF? ICH 1.05V? and to what value? Sep 28, 2012 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.