10

enter image description here

As you can in this above image there are two windows of vlc player, I just want to get rid of the other vlc direct3d output window.

VLC version is latest i.e. 2.0.1.

If I change the video output to some other also; this thing doesn't change. Only the title changes i.e. now it is direct3d output then it will change to openGL or as per the selected output video option.

This happens when I play *.mov files.

  • 2
    Weirdly, I'm getting the problem only for Lynda tutorials, like you! – Abhishek Sha Feb 8 '13 at 14:11

17 Answers 17

4

Tools > Preferences > Video

Change the output to Direct2d output

For any anyone having difficulty getting the option to stick: Press save not cancel after selecting the Direct2d setting.

  • 4
    didn't work for me – Fast Snail Feb 29 '16 at 11:36
2

I got this answer on my own. Actually this is a bug in VLC media player and they haven't solved this problem till yet. This problem is caused only when playing specific file types, in my case it was .mov file.

The answer to this problem was to use different player rather then to depend on vlc. Now,whenever I want to open this type of file I use GOM player. The .mov file is played very smoothly in GOM player without opening any more extra windows.

Sad, I even tried the latest version of vlc i.e. 2.0.2 still the problem is alive.

1

I too faced this problem. I got rid of the issue by changing the following

Tools > Preferences > Input and Codecs > (Check) Use GPU accelerated decoding Restart VLC

http://forum.videolan.org/viewtopic.php?f=2&t=100653#p355744

This is happening with Lynda.com videos. because they are putting an additional layer with the logo. in video menu there are two tracks. A temporary solution is right click the video while playing > video> video track > disable. Again same step and choose track 1. This is valid for the file being played. If you open another file you will get the popup. You will have to do the same process every time you play such files

  • I tried your suggestion but the problem still persists......Don't know when vlc will sort this problem? – FrozenKing Mar 20 '13 at 14:50
1

It's an old topic so maybe this'll help people searching for this problem.

I had the same problem on VLC 2.1.4. Rincewind with a couple of files. And indeed, it turned out that they all had 2 video streams (as well as 2 audio streams).

My solution was to load them in MKVmerge, a program that puts videos in the Matroska container format. In MKVmerge I simply disabled the superfluous video and audio streams, clicked "Start Muxing" and it created a file that worked normally in VLC and, as a bonus, took half as much disk space. If other container formats are your preference, such as MP4, there are other programs for that as well.

To me this counts as a permanent solution since the problem lies with a couple of files that could be repaired. If this problem commonly recurs for you, perhaps a competing media player such as MediaPlayer Classic would serve you better.

0

NO solution at all. Just use Classic Media Player. Beautiful result you'll obtain. It's perfect for .mov extension files.

0

You can select you desired output module in VLC preferences. In VLC go to: Tools >> Preferences

And select "All" for "Show settings". Go to "Video >> Output modules" and select e.g. "DirectX video output" from the drop down list. Press "Save" and restart VLC.

0

This is quite an old thread, but I've just tried version 2.1.2 and had the same problem.

The solution for me was to first reset the configuration and cache, followed by removing %APPDATA%\Roaming\VLC.

0

You can try to reset your preferences and cache files.

start menu -> VideoLAN -> reset preferences and cache files.

this solved my problem.

0

Go to Tools > Preferences > Show settings (select all) > Reset Preferences.

This worked for me. I hope it works for you too.

0

If you are having direct3d output problem too much than not to worry... you just have to do some steps like just go to Tools>Preference and than Reset Preference thats it. . . . thank you...

  • "Do some steps like..." Could you be more precise, please? There are already nine answers to this question so any new answers really need to give some definite information that isn't already on the page. – David Richerby May 17 '15 at 14:28
0

Go to Tools > Preferences > Audio > and set Visualization to Disable

Old thread but if someone doesn't want to reset their VLC preferences then try this it worked for me. I hope it works for you as well.

0

So I was fortunate enough to have a work computer that was configured to play the video properly and after scrolling through countless settings....

Tools > Preferences > Show settings - select the All radial (bottom left corner) Click the Video option (in the left column) and select the "Embedded Video" check box.

0

Do make sure you have the "Integrate video in interface" checkbox checked before trying all these other options.

enter image description here

0

I got this on Vetinari too. No matter what Video Output I would choose, the main interface would display an audio visualization (ProjectM) and the video would go a new pop up screen. I tried resetting the settings too but it did not work. Finally I started disabling various streams - first the Video, then brought it back; then the audio - and then video display got back to the main window. I could then re-enable audio stream and the video would remain in the main window.

0

Check Allow only one instance AND Enqueue items into playlist in one instance mode. My version of VLC is 2.2.8 Weatherwax, the better one.

  • In my case that resulted in only retaining the window with no video output – z33k May 2 at 10:47
-1

Go to tools> preference> interface. Uncheck Start in minimal view mode and check integrate video interface.

-1

Click Reset Preferences and Cache Files in VLC Media Player in Start. It will do its job.

  • 1
    "It will do its job" is a very unclear statement and makes your answer more or less incomprehensible. Please add some explanation of how this solution actually fixes the problem, especially considering this question was already answered. – music2myear Jan 31 '17 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.