I need a program to listen to port 9000 on localhost with my Windows firewall. I've created an outgoing and an incoming rule for my program but I can only see my incomming rule in the Windows firewall general menu? I've also noticed that I've many more outgoing rules in my outgoing rule menu but I can only see 4 outgoing rules in my general firewall menu but I see many many more incomming rules? The program doesn't listen to port 9000 or it doesn't working. I've also tried netstat -a -p to no avail. I didn't see in the output? How can I check if my program listen to port 9000 or connect to port 9000 when it's open?

enter image description here

  • Try this site to check if a port is open - grc.com/x/ne.dll?bh0bkyd2 - need a bit more info to help further. What program? - Is this all happening on a local network or over the internet? Have you configured your router? etc – BJ292 Jun 27 '12 at 20:47
  • I need it to listen on localhost only? Why do I have so few outgoing rules but so many incomming rules in my general menu? – Gigamegs Jun 27 '12 at 20:50
  • I'm not clear on what the problem is. (I suspect you may be XY'ing.) It sounds like you are trying to run a program that listens on port 9000, and have create an allow-rule in WF, but the program is not listening. Is that correct? – Synetech Jun 27 '12 at 21:13
  • Yes. I've some problem with a Windows host listen to a Linux Guest with xdebug on the guest and Komodo on the host. I think it's host is listen on Port 9000 (so it's the client) and xdebug is the server and the guest. It's working in localhost but not with host and guest. Hence I'm looking in this Windows Firewall. – Gigamegs Jun 27 '12 at 21:53

It sounds like you have an active filter, filtering the rules you are shown.

Click each of the filter settings to the right and set them to Show All:

enter image description here

As for monitoring, unfortunately the Windows Firewall is still a relatively light firewall that is not meant for "power users" (though the one in Windows 7 has much improved since the one in XP SP2—*cough*outbound-rules*cough*). As such, it does not provide notifications for outbound connections[1][2][3].

If you want full monitoring/reporting/alerts for your incoming and outgoing connections, you will need to a use a dedicated, third-party firewall (note however that free versions often limit these exact features).

Another options is to use a program like the Windows Firewall Notifier which acts as a shim of sorts between the Windows Firewall and the user to provide a more traditional software firewall experience.

  • No, I don't have filters and I mean the Monitor->Firewall menu. I've all my rules in inbound and outgoing but I cannot monitor the outgoing rule? – Gigamegs Jun 27 '12 at 21:01
  • Problem is the I can't see it with netstat either? Maybe Windows Firewall is good? – Gigamegs Jun 27 '12 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.