I use a virtual machine of Win XP for testing the company website in IE8. I have used it a time or two but now I'm having strange issues. The host machine is Win7 x64 running Microsoft Virtual PC to emulate WinXP x86. The host machine's networking is fine. Here's what the VM can and can't do:

  • Can ping an external site by name (i.e. "ping google.com" works) and IP
  • Can ping an internal computer by name and IP
  • Cannot browse to any internal or external site by name or IP
  • Can download and install Windows Updates

I thought that maybe it was my network adapter settings in Virtual PC, but no matter how much I change them, I make no progress. The list above has "Shared networking (NAT)" set as my only Network adapter in Virtual PC.

I only need the VM to be able to view the webapp on the host machine. I have tried looking at the firewall settings and with both the host and VM firewalls completely turned off, I still can't connect.

ipconfig lists the same DNS suffix, subnet mask (, and default gateway ( as the host machine but what is interesting is that the VM IP address doesn't match the subnet mask and gateway, it's I have tried setting a static IP with no success.

I do not recall doing anything that would affect the VM like this. Perhaps there's a Windows Update that did this, but I don't know for sure.


As I was writing this question, I noticed that the "net view" command returned error 6118. After a little googling, I found this support article and the cause bluntly says "Your workgroup name is different than your domain name." After putting my VM on the domain under my own name, I connected with no problem to not just my host machine but the rest of the internet (which was necessary for my VM to run the webapp).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.