Google Chrome has begun an annoying habit recently of auto-pinning itself to my quicklaunch bar in Windows 7, at seemingly random times and no matter how many times I manually unpin it. It doesn't seem to be tied to automatic updates; I've noted the version and manually unpinned, and confirmed that the version is the same the next time it pins itself. I'd like to disable this behavior, but haven't found the option in Settings. Any ideas how to fix this?

My current version of Chrome is 20.0.1132.43.

5 Answers 5


This one was VERY tricky, since Google Chrome doesn't use any of the conventional means to pin an icon to the taskbar and the desktop. However, there is a specific area of the registry that, if deleted, prevents this behavior. The contents of HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components{8A69D345-D564-463c-AFF1-A69D9E530F96} in .reg file format are:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{8A69D345-D564-463c-AFF1-A69D9E530F96}]
@="Google Chrome"
"StubPath"="\"C:\\Program Files\\Google\\Chrome\\Application\\24.0.1312.52\\Installer\\setup.exe\" --configure-user-settings --verbose-logging --system-level --multi-install --chrome"
"Localized Name"="Google Chrome"


[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components\{8A69D345-D564-463c-AFF1-A69D9E530F96}]

...then Chrome stops pinning itself to everything with every new user. In testing, the only ill effect is that it seems you will need to add a shortcut to Chrome to the Start Menu (I guess the setup.exe program adds the shortcut as well).

Hope this helps...


user190509's answer seems correct and was very helpful to me. I would just add that on Windows 7x64 the registry key is:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Active Setup\Installed Components\{8A69D345-D564-463c-AFF1-A69D9E530F96}

This fix worked for me with Chrome 36.0.1985.125.


Open 'C:\Program Files (x86)\Google\Chrome\Application\master_preferences' (as Administrator).

To remove the Chrome taskbar shortcut:
Append "do_not_create_taskbar_shortcut":true
i.e. {"distribution":{"make_chrome_default_for_user":true,"do_not_create_taskbar_shortcut":true}

To remove the Chrome desktop shortcut:

To remove the Chrome taskbar, desktop and start menu:
"do_not_create_any_shortcuts" : true

See here for more details

I recommend leaving Active Setup for Chrome alone (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components{8A69D345-D564-463c-AFF1-A69D9E530F96} for 32bit, HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Active Setup\Installed Components{8A69D345-D564-463c-AFF1-A69D9E530F96} for 64bit).


if you move an icons position on the bar while its open it will also add it as pinned to that place.

this may be a irrelevant to you, but at any point to you click and perhaps hold the icon a bit too long, which activates the move/sort icon action of icons on the bar? or actually moved the chrome icon on your bar? if either of these are true this will be what is happening for you.


"do_not_create_any_shortcuts":true works like a champ, however, it MUST be placed in the "distribution:" section of the master_preferences file, ie:

{"homepage":... "distribution":{"skip_first_run_ui":false,"import_search_engine":false,"do_not_create_any_shortcuts":true}...}

Not the answer you're looking for? Browse other questions tagged or ask your own question.